Login  |  Register
Nissanhelp.com - All About Nissan
2018 Altima 2018 Armada 2018 Frontier 2018 GTR 2018 LEAF 2018 Maxima 2018 Murano 2018 NV 2018 Pathfinder 2018 Rogue 2018 Sentra 2018 Titan XD 2018 Versa Note 2018 Versa Sedan 2018 Z
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > Blinkers not always working
Forgot Password? Join Us!


Xterra Nissan Xterra Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 01-18-2018, 05:41 PM
chlpz chlpz is offline
Registered User
2012 Xterra
 
Join Date: Jan 2018
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Blinkers not always working

2012 Xterra pro-4x

I've been having issues with my blinkers not wanting to flash on the first time I turn them on. It takes maybe 2 or 3 times of me to try to turn my blinkers on, this also happens with the hazards. I have taken it to the shop and they have no idea what it is. Ive changed the bulbs and it is still not working. Is it the relay?

PLEASE HELP
Reply With Quote
  #2  
Old 01-18-2018, 05:47 PM
mpe235's Avatar
mpe235 mpe235 is offline
Moderator
2015 Rogue
 
Join Date: Jun 2006
Location: New York
Posts: 5,501
Thanks: 5
Thanked 252 Times in 235 Posts
Default

Quote:
Originally Posted by chlpz View Post
2012 Xterra pro-4x

I've been having issues with my blinkers not wanting to flash on the first time I turn them on. It takes maybe 2 or 3 times of me to try to turn my blinkers on, this also happens with the hazards. I have taken it to the shop and they have no idea what it is. Ive changed the bulbs and it is still not working. Is it the relay?

PLEASE HELP
Do you have aftermarket trailer wiring installed?
Reply With Quote
  #3  
Old 01-18-2018, 05:54 PM
NissanTech's Avatar
NissanTech NissanTech is offline
Super Moderator
2004 Xterra
 
Join Date: Jun 2005
Location: California
Age: 47
Posts: 12,704
Thanks: 473
Thanked 586 Times in 525 Posts
Default

Unfortunately, I haven't seen that problem. There is no relay, the BCM controls both the turn signals and hazard lights. Try disconnecting the Hazard switch and see if that make any difference. My best guess is that the switch is causing a problem.

Blinkers not always working-capture-png
Attached Thumbnails
Blinkers not always working-capture-png  
__________________
Need A Repair Shop?
Find local automotive repair shops in your area.
AutoCodes.com Shops
Reply With Quote
  #4  
Old 01-18-2018, 06:02 PM
chlpz chlpz is offline
Registered User
2012 Xterra
 
Join Date: Jan 2018
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by NissanTech View Post
Unfortunately, I haven't seen that problem. There is no relay, the BCM controls both the turn signals and hazard lights. Try disconnecting the Hazard switch and see if that make any difference. My best guess is that the switch is causing a problem.

Ok I will try that! Thanks!
Reply With Quote
Reply

Bookmarks

Tags
blinkers, working

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:53 PM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2018 Nissanhelp.com
AutoCodes.com - Engine-Codes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.