Login  |  Register
Nissanhelp.com - All About Nissan
2018 Altima 2018 Armada 2018 Frontier 2018 GTR 2018 LEAF 2018 Maxima 2018 Murano 2018 NV 2018 Pathfinder 2018 Rogue 2018 Sentra 2018 Titan XD 2018 Versa Note 2018 Versa Sedan 2018 Z
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > 2010,xterra,turn signals
Forgot Password? Join Us!


Xterra Nissan Xterra Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-19-2017, 11:53 AM
barnacle barnacle is offline
Registered User
2010 Xterra
 
Join Date: Feb 2017
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default 2010,xterra,turn signals

With the key in the on position I have everything doing what it is suppose to be doing including the hazards. When I start the car I have everything except the turn signals and hazards. And when I try L/R & hazards I get a quick couple of blinks and then nothing, I can do some playing with them and sometimes they'll work until I move the control switch or push the hazard. ( almost like there out of sink ) checked every fuse,relay,cleaned and double checked grounds. There is no LEDs or resisters that I can find , no tow package. I can't find anything wrong with the control switch with my tester. ( but have a brand new one coming anyway) I'm thinking BCM ! or other related things to the signals but just don't know. Everything has a circuit board in it so i am limited as to getting to the bottom of it .
Reply With Quote
Reply

Bookmarks

Tags
2010, signals, turn, xterra

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:36 PM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2018 Nissanhelp.com
AutoCodes.com - Engine-Codes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.