Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Is this my Xtrail Heater Fan Resistor? Forums > > > Is this my Xtrail Heater Fan Resistor? Is this my Xtrail Heater Fan Resistor?
Forgot Password? Join Us!


Reply
 
Thread Tools Display Modes
  #1  
Old 08-15-2012, 01:41 AM
bdjames bdjames is offline
Registered User
2004 Xtrail
 
Join Date: Aug 2012
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Default Is this my Xtrail Heater Fan Resistor?

Hi everyone,

I have been reading every forum entry I can find regarding Xtrail heater fan resistor problems. I have a classic resistor failure scenario - fan only works on setting 4 - and I wish to replace it. Before I attempt to find a replacement part (I am in NZ) I thought I would make sure I could locate the offending item in the car and remove/replace it.

Firstly, I am not a car-tech person, but the instructions I have read seem simple enough. So, I removed the cover beneath the glovebox and looked up. After a lot of searching (and back-breaking contortions) I found what I think might be the resistor. It is at the back of what I assume is the blower cover (which is white?) and it is set into another piece of bodywork. It has a large plug into it and is secured by two fairly fat screws. I took a photo and have uploaded it in the hope that someone can confirm that I have located the right part! Can anybody help with this?

Brian
Attached Thumbnails
Is this my Xtrail Heater Fan Resistor?-dsc_0034-jpg  
Reply With Quote
The Following User Says Thank You to bdjames For This Useful Post:
  #2  
Old 05-26-2013, 07:45 PM
chamz5 chamz5 is offline
Registered User
2007 Xtrail
 
Join Date: May 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi!
Yes that is the module that controls the fan speeds. I had the same problem with only speed 4 (hi) working.
Remove this item & replace & all will be good!
I found one at a local jap parts place in Sydney for $75.
Reply With Quote
  #3  
Old 05-26-2013, 11:02 PM
bdjames bdjames is offline
Registered User
2004 Xtrail
 
Join Date: Aug 2012
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi chamz5,

thanks for your reply. I swapped the unit out a while back and all is fine now :-)
Reply With Quote
Reply

Bookmarks

Tags
fan, heater, resistor, xtrail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:13 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.