Login  |  Register
Nissanhelp.com - All About Nissan
2018 Altima 2018 Armada 2018 Frontier 2018 GTR 2018 LEAF 2018 Maxima 2018 Murano 2018 NV 2018 Pathfinder 2018 Rogue 2018 Sentra 2018 Titan XD 2018 Versa Note 2018 Versa Sedan 2018 Z
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > engine cranks but won't start
Forgot Password? Join Us!


Titan Nissan Titan Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 01-16-2012, 06:37 AM
crobinson crobinson is offline
Registered User
2008 Titan Crew Cab
 
Join Date: Jan 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default engine cranks but won't start

About a week ago I changed the battery and air filter in my 2008 titan. It cranked longer than normal but started and has ran fine since. Now it cranks but won't fire.
Reply With Quote
  #2  
Old 01-16-2012, 11:53 AM
bennyb53's Avatar
bennyb53 bennyb53 is offline
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 2,089
Thanks: 45
Thanked 250 Times in 242 Posts
Default

Is "service engine soon" light on? Even if not on, scan ECM for trouble codes.
Reply With Quote
  #3  
Old 01-25-2012, 09:12 AM
bobbyrk bobbyrk is offline
Registered User
2001 Altima
 
Join Date: Aug 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

check the starter fuse. Even though the engines cranks over, we found the starter fuse was the problem
Reply With Quote
  #4  
Old 02-08-2017, 11:42 PM
MixerO MixerO is offline
Registered User
2005 Titan Crew Cab
 
Join Date: Oct 2016
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Check the 10A IGN fuse.
Also I've read it could be the Fuel pump.

ECM computer relay
Reply With Quote
  #5  
Old 05-30-2017, 01:49 AM
danello danello is offline
Registered User
2012 Titan Crew Cab Titan Crew Cab
 
Join Date: May 2017
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It could be the fuel pump or sending unit also.
Reply With Quote
  #6  
Old 05-30-2017, 09:53 AM
smj999smj's Avatar
smj999smj smj999smj is offline
Master Enthusiast
2006 Pathfinder
2003 Frontier King Cab
2003 Frontier SVE
 
Join Date: Jun 2012
Location: Prospect, VA
Posts: 1,540
Thanks: 1
Thanked 234 Times in 217 Posts
Default

Or a crank or cam position sensor... There are a lot of "could be's." First thing to do is check to see if it's a fuel delivery problem or an ignition problem if there are no stored codes to help diagnose the problem. Spray carb cleaner into the intake and see if it will "fire" on it. If it does, then the problem is a fuel delivery issue. If it doesn't, then either there is an ignition problem or the plugs are badly fouled. So, check for spark to the plugs. Cam position sensor and crank position sensor failures are more common on these vehicles than failed fuel pumps, but, it's best to diagnose the fault of the problem rather than just throw parts at it.
Reply With Quote
Reply

Bookmarks

Tags
cranks, engine, start, wonr

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:57 PM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2018 Nissanhelp.com
AutoCodes.com - Engine-Codes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.