Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
07 Quest no cooling fans Forums > > 07 Quest no cooling fans 07 Quest no cooling fans
Forgot Password? Join Us!


Quest Nissan Quest Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 06-21-2018, 08:47 AM
artsalfa artsalfa is offline
Registered User
2007 Quest
1979 280ZX
 
Join Date: Jun 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default 07 Quest no cooling fans

Owned since new, now 100K, this will be third time I have replaced the radiator cooling fans? Wondering if there are any fuses involved too?
Reply With Quote
  #2  
Old 06-22-2018, 07:36 AM
artsalfa artsalfa is offline
Registered User
2007 Quest
1979 280ZX
 
Join Date: Jun 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok with 27 views and no responses, guess no one knows anything more than I do on here, replaced fans and had to replace connecting plugs because they were corroded/melted into the fan sockets. Found and spliced in a new pair from used. But still no fans on? I checked both fuses which say blower motor in the under engine small fuse panel and wiggled a relay. Unsure but believe that is the actual AC blower. Assuming now there is a sensor which has gone bad but clueless as to what and where it is? Any help appreciated.
Reply With Quote
  #3  
Old 06-23-2018, 01:14 AM
Howard Bell Howard Bell is offline
Enthusiast
2011 Versa
2017 Altima SE-R
 
Join Date: May 2018
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Fans pull a LOT of amp and you need to make sure any new wiring there is up to the task at connections. Might chase down the relay(s), if the amp load melted the plugs then likely the relay and/or relay socket may be burned at the contacts too.



3X changing fans in 100K screams something is wrong to me...............
Reply With Quote
Reply

Bookmarks

Tags
cooling, fans, quest

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:23 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.