Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
help !! 2005 quest cranks no start cooling fans on security light on Forums > > help !! 2005 quest cranks no start cooling fans on security light on help !! 2005 quest cranks no start cooling fans on security light on
Forgot Password? Join Us!


Quest Nissan Quest Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 09-26-2016, 05:15 PM
05nisquest 05nisquest is offline
Registered User
2005 Quest
 
Join Date: Sep 2016
Posts: 5
Default help !! 2005 quest cranks no start cooling fans on security light on

2005 quest cranks no start the cooling fans come on few seconds after the key is turned on also the red key security light is on solid when the key is on car drove fine parked it for 2 days had some rain yesterday weird! tried disconnecting the battery for 20 minutes didn't work
Reply With Quote
  #2  
Old 09-27-2016, 01:51 AM
bennyb53's Avatar
bennyb53 bennyb53 is offline
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 2,102
Default

Scan computer for trouble codes.
Reply With Quote
  #3  
Old 09-27-2016, 10:42 AM
05nisquest 05nisquest is offline
Registered User
2005 Quest
 
Join Date: Sep 2016
Posts: 5
Default

dont have access to a code reader right at this moment ! a little bit of an update got it to start and run a little bit with the unlocking and locking the door with the key attempted to take it around the block kept shutting off but would restart and shut off . then the fuel pump would kick on and off like glitching with the check engine light was weird then wouldn't start at all then went back to the fans on and security light on no start
Reply With Quote
  #4  
Old 09-28-2016, 07:08 AM
05nisquest 05nisquest is offline
Registered User
2005 Quest
 
Join Date: Sep 2016
Posts: 5
Default

took the ecu out was corroded not all the way through .cleaned it up .could it have got wet some how ?when the ecu fries does the security light come on?

Last edited by 05nisquest; 09-28-2016 at 09:22 AM.
Reply With Quote
  #5  
Old 09-28-2016, 06:21 PM
smj999smj's Avatar
smj999smj smj999smj is online now
Master Enthusiast
2006 Pathfinder
2003 Frontier King Cab
2003 Frontier KC SVE 4x4
 
Join Date: Jun 2012
Location: Prospect, VA
Posts: 1,800
Default

If there was corrosion, them moisture got inside. Cooling fans on all the time is a fail safe mode when there is an issue with the ECM and numerous other issues can occur, as well. Once corrosion is inside the ECM, the safe bet is to send it out and have it checked/repaired by a place that does this (i.e. Circuit Board Medics) or replace the unit. If the problems stop and you feel confident all of the corrosion is cleaned out and there is no damage to the circuit board, you can gamble, but you'll still want to address the issue of how water got in there to begin with.
Reply With Quote
Reply

Bookmarks

Tags
2005, cooling, cranks, fans, light, quest, security, start

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 10:33 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.