Nissanhelp.com Forums

Nissanhelp.com Forums (https://x.nissanhelp.com/forums/)
-   Versa (https://x.nissanhelp.com/forums/versa/)
-   -   Speedometer & Odometer Not Accurate (https://x.nissanhelp.com/forums/versa/31858-speedometer-odometer-not-accurate.html)

JCF 01-16-2020 06:45 AM

Speedometer & Odometer Not Accurate
 
Last summer I purchased a used 2011 Versa Hatchback and after a month of driving it I noticed that the speedometer and odometer were inaccurate. This was determined by driving a known route and later by comparing to a GPS.



The speedometer reads 93% of the actual speed. So if the speedometer indicates 65 MPH the actual speed is 70 MPH.


The odometer is indicating more mileage than actually traveled. The actual mileage is 96% of what is indicated by the odometer. On a trip of 421.7 miles (GPS) the odometer indicated 437.5 miles. That's 15.8 miles difference.


The tires are the correct size and pressure so I know that isn't the cause of the difference.


How do I get this fixed?

mpe235 01-18-2020 05:16 PM

Quote:

Originally Posted by JCF (Post 108336)
Last summer I purchased a used 2011 Versa Hatchback and after a month of driving it I noticed that the speedometer and odometer were inaccurate. This was determined by driving a known route and later by comparing to a GPS.



The speedometer reads 93% of the actual speed. So if the speedometer indicates 65 MPH the actual speed is 70 MPH.


The odometer is indicating more mileage than actually traveled. The actual mileage is 96% of what is indicated by the odometer. On a trip of 421.7 miles (GPS) the odometer indicated 437.5 miles. That's 15.8 miles difference.


The tires are the correct size and pressure so I know that isn't the cause of the difference.


How do I get this fixed?

There was a recall issued to fix that problem. You should contact a dealer to see if it was done on your vehicle.

JCF 01-21-2020 07:30 AM

Quote:

Originally Posted by mpe235 (Post 108342)
There was a recall issued to fix that problem. You should contact a dealer to see if it was done on your vehicle.


I found out that the recall expired in April of 2019.
The local dealer said it would cost $130 + tax to reprogram it. Is that something that can be done as a DIY project or does it take specialized equipment?

mpe235 01-23-2020 02:21 AM

Quote:

Originally Posted by JCF (Post 108366)
I found out that the recall expired in April of 2019.
The local dealer said it would cost $130 + tax to reprogram it. Is that something that can be done as a DIY project or does it take specialized equipment?

It requires 2 special tools to program .

JCF 01-29-2020 11:41 AM

Quote:

Originally Posted by mpe235 (Post 108369)
It requires 2 special tools to program .


I took my car into the Nissan dealer this morning to get the speedometer
and odometer fixed. After all the info was looked up the estimated cost
jumped from $130 + tax to $260 + tax. The increase was because the fix
requires the instrument cluster needs to pulled out and and plugged into
another contraption that updates the firmware in a electronic device
located in the instrument cluster. He also said on rare occasions it
will fry the thing and then I would have to replace the cluster
.

What really concerns me more than the cost if the possibility of frying the unit.



Do you have any idea how common or rare that really is?

mpe235 01-30-2020 02:38 AM

Quote:

Originally Posted by JCF (Post 108373)
I took my car into the Nissan dealer this morning to get the speedometer
and odometer fixed. After all the info was looked up the estimated cost
jumped from $130 + tax to $260 + tax. The increase was because the fix
requires the instrument cluster needs to pulled out and and plugged into
another contraption that updates the firmware in a electronic device
located in the instrument cluster. He also said on rare occasions it
will fry the thing and then I would have to replace the cluster
.

What really concerns me more than the cost if the possibility of frying the unit.



Do you have any idea how common or rare that really is?

I have never had a problem with one not working after the program. I have also never heard of that happening.

smj999smj 02-04-2020 10:55 AM

Usually doesn't happen...but, as we call in the industry: "covering their ass."


All times are GMT -8. The time now is 04:35 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.