Nissanhelp.com Forums

Nissanhelp.com Forums (https://x.nissanhelp.com/forums/)
-   Altima (https://x.nissanhelp.com/forums/altima/)
-   -   09 Altima 2.5L rough idle, no codes. Thoughts? (https://x.nissanhelp.com/forums/altima/31136-09-altima-2-5l-rough-idle-no-codes-thoughts.html)

dianaraven 10-17-2018 06:57 AM

09 Altima 2.5L rough idle, no codes. Thoughts?
 
90k on it. It started with shaking in D & R when stopped, but no shaking in P & N. The right engine mounts were replaced, which didn't help much with the shaking, although they needed to be replaced. Spark plugs were also replaced and my mechanic cleaned the throttle body as best he could. Also ran fuel injector cleaner. But it's still shaking. Now it's bad in D & R, but also getting worse in P & N. It's also worse when it's raining or cold. BUT NO CODES EVER!

It looks like the ignition coil connector wires are cracked and exposed. Could this be the issue? I have parts coming to change them out myself. It looks like a relatively simple job, but any hints would be helpful.

I also tried checking for vacuum leaks with carb cleaner, but didn't find anything. I plan on trying again. Any other ideas for what to look at, besides getting the left engine mounts replaced?

Thanks

jcg0324 11-13-2018 01:42 AM

If you have a scan tool, you can use it check the readout under mode 6. Mode 6 many times will display problems creeping up in various systems before they are bad enough to trigger a "check engine soon" light.

Soapmyster 11-17-2018 04:26 PM

Sure sounds like weak coils. They dont always throw a code.
Be sure your grounds are good as that is the worst enemy for coil packs


All times are GMT -8. The time now is 11:05 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.