Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Hard to Start when engine is hot Forums > > Hard to Start when engine is hot Hard to Start when engine is hot
Forgot Password? Join Us!


Pathfinder Nissan Pathfinder Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 10-23-2018, 11:55 AM
CaptFran CaptFran is offline
Registered User
2008 Pathfinder
 
Join Date: Oct 2018
Posts: 2
Default Hard to Start when engine is hot

I have a 2008 Nissan Pathfinder with 205K mikes. Still runs great. However, it is now giving me problems starting when the engine has warmed up. If I go to the store and park, shop for a while then come back and try to start the car, it will crank over but will not start. After a few tries and waiting for 5 minutes, it will eventually starts. But it runs very rough and stalls the first time of two. it eventually starts and runs fine. The parts that have been replaced already are, Battery, Fuel Pump, Crank Shaft Sensor and Coolant Temperature Sensor. The Fuel Pump was replaced when the gauge stopped working and it gave an error code. After a few months I got another error code which said I had a bad Crankshaft Sensor. That sensor was then replaced. The problem of NOT STARTING WHEN ENGINE WAS WARMED UP started a few months after the fuel pump had been replaced. I DON'T have any errors code on the hard starting problems. Could I have a bad fuel pump? Could a Throttle Body and Sensor be giving me a problem? Very Frustrating as I don't know when this will become a hard problems and end up never starting. Then will need to get a tow to a garage. When I brought it to my mechanic, it started ok and he could find any error codes. Thanks
Reply With Quote
  #2  
Old 10-25-2018, 11:03 AM
smj999smj's Avatar
smj999smj smj999smj is offline
Master Enthusiast
2006 Pathfinder
2003 Frontier King Cab
2003 Frontier KC SVE 4x4
 
Join Date: Jun 2012
Location: Prospect, VA
Posts: 1,785
Default

If it were me, I would first have the fuel pressure tested; it should be 50 PSI. You could also do a leakdown test at the same time to make sure one or more fuel injectors aren't bleeding down during a sit or the regulator has failed. If the fuel system checks out okay, I would replace the two cam position sensors. A bad cam position sensor can cause a crank position sensor to trigger...and, it can also be faulty and not trigger any codes. Often, the failures occur when they get hot, which seems to be what your vehicle is doing. It's best to stick with genuine Nissan sensors, if possible. Some of the aftermarket sensors tend to be of poor quality and either don't work right brand new or don't last long. If you can't get Nissan sensors, than Hitachi brand or an aftermarket sensor that was made in Japan, like Standard Motor Products/Intermotor brand, would be the next best. Avoid sensors made in China, Taiwan or Korea and other countries close by. Hopefully, you did that when you replaced the crank position sensor.
Reply With Quote
  #3  
Old 10-25-2018, 11:31 AM
CaptFran CaptFran is offline
Registered User
2008 Pathfinder
 
Join Date: Oct 2018
Posts: 2
Default Hard to Start when engine is hot.

Yes the Crank Sensor was an OEM product but it was upgraded, from its original form factor. The mechanic had to call Nissan again to determine how it could be modified to fit. Once modified and the codes were cleared, I still had the problem after a day or two. I will certainly give the suggestions to my mechanic and make sure they do the fuel injector pressure test as recommended. If that doesn't fix the problem, the cam sensors are next. I will let everyone know the outcome. Thanks again for your suggestions. I love the car when it runs.
Reply With Quote
Reply

Bookmarks

Tags
engine, hard, hot, start

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 01:46 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.