Login  |  Register
Nissanhelp.com - All About Nissan
2018 Altima 2018 Armada 2018 Frontier 2018 GTR 2018 LEAF 2018 Maxima 2018 Murano 2018 NV 2018 Pathfinder 2018 Rogue 2018 Sentra 2018 Titan XD 2018 Versa Note 2018 Versa Sedan 2018 Z
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > Service Engine Soon
Forgot Password? Join Us!


Pathfinder Nissan Pathfinder Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2009, 12:01 PM
dsm0274 dsm0274 is offline
Enthusiast
2005 Pathfinder
 
Join Date: May 2009
Posts: 40
Thanks: 0
Thanked 7 Times in 4 Posts
Default Service Engine Soon

had my oil changed about 3 days ago soon after i noticed a rattling sound when the car idles(occasionally) i assumed they forgot to tighten the skid plate they remove to get to the oil filter, returned to service center and they said it all looked good but there was a loose clamp on the heat shield further towards the back of the car, they in fact removed it and showed it to me were it was rusted through, it looked like a metal band and didn't have any way to tighten it or loosen it almost like a metal zip tie, so away i went and drove for another 1 or 2 hours (actually used 4 wheel drive for about 15 minutes while checking game camera) just before i pulled into drive way service engine soon light came on. i checked fuel cap(i did put gas in) checked engine temp. checked coolant level all appeared normal any ideas without using a code reader? will be going out to check engine oil momentarily but the gauges looked good while i was driving. 2005 Nissan pathfinder 47,000 miles
Reply With Quote
  #2  
Old 06-22-2009, 03:30 PM
mpe235's Avatar
mpe235 mpe235 is offline
Moderator
2015 Rogue
 
Join Date: Jun 2006
Location: New York
Posts: 5,503
Thanks: 5
Thanked 252 Times in 235 Posts
Default

My guess would be a fuel level sensor. They usually set codes after refuelling. Keep an eye on your fuel gauge to see if you notice any major fluctuations.
__________________
Nissan Master certified Technician
Hybrid and GTR certified
EV certified
ASE Master Certified.
Reply With Quote
  #3  
Old 06-22-2009, 08:01 PM
dsm0274 dsm0274 is offline
Enthusiast
2005 Pathfinder
 
Join Date: May 2009
Posts: 40
Thanks: 0
Thanked 7 Times in 4 Posts
Default

is there a fix for this?? or are we talking a new fuel sensor?
Reply With Quote
  #4  
Old 06-23-2009, 02:26 AM
mpe235's Avatar
mpe235 mpe235 is offline
Moderator
2015 Rogue
 
Join Date: Jun 2006
Location: New York
Posts: 5,503
Thanks: 5
Thanked 252 Times in 235 Posts
Default

Quote:
Originally Posted by dsm0274 View Post
is there a fix for this?? or are we talking a new fuel sensor?
New fuel level sensor.
Reply With Quote
  #5  
Old 06-23-2009, 07:16 AM
dsm0274 dsm0274 is offline
Enthusiast
2005 Pathfinder
 
Join Date: May 2009
Posts: 40
Thanks: 0
Thanked 7 Times in 4 Posts
Default

just went to auto zone and found out they will run the code reader on your car for free---code 0455 returned gross leak in the evap system. i think this has to do with the gas cap being left off--i know there is probably a lot of discussions on here about this so if some one coud point me to the thread it would help. how ong for the code to reset itself---the only time i remember leaving the gas cap off was about 4 weeks ago and i drove about 25 miles like that?? would it take that long for the code to come up??
Reply With Quote
  #6  
Old 06-23-2009, 01:38 PM
tech22's Avatar
tech22 tech22 is offline
Master Enthusiast
2005 Frontier Crew Cab Frontier Crew Cab
05 nissan frontier
 
Join Date: Jan 2008
Location: alliance,ohio
Age: 65
Posts: 2,049
Thanks: 0
Thanked 14 Times in 13 Posts
Default

Not for a gross evap leak.
Reply With Quote
  #7  
Old 06-27-2009, 11:24 AM
dsm0274 dsm0274 is offline
Enthusiast
2005 Pathfinder
 
Join Date: May 2009
Posts: 40
Thanks: 0
Thanked 7 Times in 4 Posts
Default

got an update---ses light when off for about 1 day then came back on---i played with the little spring inside the gas cam to see if it was working right and it seemed OK but i guess i don't know what OK is-- i placed a plastic bag over the filler neck and put the gas cap on hoping this would tell me if the problem is there--how long would it take for the light to go out?? running low on gas and i want to finish this experiment before i put more gas in. gas gage and DTE readings all appear normal and drivability is ok that is why i am thinking it is gas cap--been looking through diagrams and don"t think i cold isolate the problem myself by taking the evap canister off
Reply With Quote
Reply

Bookmarks

Tags
oile change heat shield

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:37 PM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2018 Nissanhelp.com
AutoCodes.com - Engine-Codes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.