Login  |  Register
Nissanhelp.com - All About Nissan
2018 Altima 2018 Armada 2018 Frontier 2018 GTR 2018 LEAF 2018 Maxima 2018 Murano 2018 NV 2018 Pathfinder 2018 Rogue 2018 Sentra 2018 Titan XD 2018 Versa Note 2018 Versa Sedan 2018 Z
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > Blower problems
Forgot Password? Join Us!


Other Nissan Vehicles Other Nissan Vehicles Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 05-04-2016, 10:19 PM
dogteam dogteam is offline
Registered User
2005 Xtrail
 
Join Date: May 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Blower problems

Looking for some help on my 2005 Xtrail....the other day, I put the fan on Max for a few minutes (very hot day) but when I tried to turn it down or off, it would not. Fan ran full blast until ignition turned off. On restarting, the fan was off, but as soon as I turned the speed control it went Max and stayed there again. Sounds like the resistor, right? Was all prepared to take care of that, but next day.... Nothing. No fan, on any setting. Pulled the resistor card, and it looks fine. Seems to not have any open traces as per ohmmeter. So what next? The control itself? This is a basic a/c system, no auto control. Hate to buy a new resistor, dealer says 85 bucks! Really it looks and tests good.
Reply With Quote
  #2  
Old 05-05-2016, 11:15 AM
bennyb53's Avatar
bennyb53 bennyb53 is offline
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 2,090
Thanks: 45
Thanked 250 Times in 242 Posts
Default

1. When it only works on high setting, it usually mean a failed blower motor resistor.
2. Now there's no power - check the fuse. I believe the circuit diagram is in HVAC manual or Ground and Power Supply manual. Manuals are in Knowledgebase section of the menu tab at the top of the page.
Reply With Quote
  #3  
Old 05-05-2016, 01:25 PM
dogteam dogteam is offline
Registered User
2005 Xtrail
 
Join Date: May 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bennyb53 View Post
1. When it only works on high setting, it usually mean a failed blower motor resistor.
2. Now there's no power - check the fuse. I believe the circuit diagram is in HVAC manual or Ground and Power Supply manual. Manuals are in Knowledgebase section of the menu tab at the top of the page.
I will check fuses. But...this morning I turned on the fan out of curiosity (the resistor is still out of the harness) and the fan came on full speed...for a couple of seconds, then died again. Wasn't expecting that...

dt
Reply With Quote
  #4  
Old 05-05-2016, 05:25 PM
dogteam dogteam is offline
Registered User
2005 Xtrail
 
Join Date: May 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

As I said, the resistor looks fine. It tests fine. It even smells fine. I think it's fine.
The selector switch, however, is melted into an unrecognizable lump; surprised there was no fire. Now the question is why? Probably the cheap blower motor is dying and drawing too many amps. You would think the fuse would blow.
Reply With Quote
  #5  
Old 05-05-2016, 05:59 PM
bennyb53's Avatar
bennyb53 bennyb53 is offline
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 2,090
Thanks: 45
Thanked 250 Times in 242 Posts
Default

Quote:
Originally Posted by dogteam View Post
The selector switch, however, is melted into an unrecognizable lump; surprised there was no fire.
You have a major short. The reason the high setting works because it is on a different circuit as a Fail Safe design. So check for damaged wires and loose body ground connections
Reply With Quote
  #6  
Old 05-05-2016, 06:18 PM
dogteam dogteam is offline
Registered User
2005 Xtrail
 
Join Date: May 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bennyb53 View Post
You have a major short. The reason the high setting works because it is on a different circuit as a Fail Safe design. So check for damaged wires and loose body ground connections
Wonderful
Any idea where I should look?

dt
Reply With Quote
  #7  
Old 05-06-2016, 12:28 PM
bennyb53's Avatar
bennyb53 bennyb53 is offline
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 2,090
Thanks: 45
Thanked 250 Times in 242 Posts
Default

1. You can start by doing visuals to inspect wiring. Starting from fan switch and just trace the wiring. You may have to unwrap the wiring as there's no way to tell. Check the fuse, replace if blown. Replace the fan switch and keep an eye if problem persists.
2. You can also test for power drain while car is not running. Power drain meaning beyond acceptable level for your vehicle around 50mA. You don't mention battery drain so probably not an issue.
3. As I've mentioned get the circuit diagram. Check on ebay or amazon for resistor. You probably can get a new one for under $20.
Reply With Quote
  #8  
Old 05-06-2016, 02:26 PM
dogteam dogteam is offline
Registered User
2005 Xtrail
 
Join Date: May 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Benny , for all the good tips. That should keep me busy for a while. You wouldn't change out the motor first, as long as it runs?
Reply With Quote
Reply

Bookmarks

Tags
blower, problems

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:30 AM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2018 Nissanhelp.com
AutoCodes.com - Engine-Codes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.