Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Am I the only one with this problem???? Forums > > Am I the only one with this problem???? Am I the only one with this problem????
Forgot Password? Join Us!


Nissan Z Nissan 240Z, 260Z, 280Z, 280ZX, 300ZX, 350Z, 370Z, Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 05-14-2009, 11:17 AM
dgf12l
Guest
 
Posts: n/a
Default Am I the only one with this problem????

ok here's the scoop.... i have a 2004 350z performance 5AT. 3.9 Final Drive Gears and some other mods to the engine...nothing major. My first problem started as soon as i got the car... when i would go WOT or even 3/4 throttle the car wouldn't shift and act like it got thrown out of gear in Drive..... in manual mode it would do the same then go over to DRIVE after it shifted extremely hard.... dealership said it could be valve body or wiring harness.. after closer inspection my wiring harness looked good so they replaced valve body. now it shifts GREAT!!! but... it will only go into manual mode in first gear and then go back over into drive and not switch back but doesn't shift hard just moves from 1 to D and works fine afterward... also my service engine light is on and the A/T light flashes a few times as soon as i start the car up.... my dealership says it's throwing a speedo code or something because it needs an ecu reflash because of the gears ... i know this to be a load of crap b/c the gears wouldn't effect it shifting. I'm thinking they just don't want to have to fix the tranny under warranty.... but either way i really really want a fullyy functional car! PLEASE PLEASE HELP!!
Reply With Quote
  #2  
Old 05-16-2009, 05:25 PM
erichantioch
Guest
 
Posts: n/a
Default

you know if you changed the final drive gears to 3.90's or whatever and it wasn't done by the dealership they have no obligation to fix your transmission as you have voided the warranty...I have heard because of the speed sensors and the way it effects the computers calibrations for timing fuel ratio ect that even putting tires of a different aspect ratio will void your drivetrain warranty
Reply With Quote
  #3  
Old 05-17-2009, 09:10 PM
dgf12l
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by erichantioch View Post
you know if you changed the final drive gears to 3.90's or whatever and it wasn't done by the dealership they have no obligation to fix your transmission as you have voided the warranty...I have heard because of the speed sensors and the way it effects the computers calibrations for timing fuel ratio ect that even putting tires of a different aspect ratio will void your drivetrain warranty

that is true in most cases but the trans was put in after the gears which shouldn't be a prob. for warranty work.... they didn't say it voided the warranty thank goodness but they did say that they don't know how to fix it..... the code i'm getting is P0720 VSS A/T anyone know why this wouldn't let me put my car in manual mode? i can put the shifter over there physically but it goes into 1st for about 3000rpm then goes back to D
Reply With Quote
  #4  
Old 06-10-2009, 01:11 AM
xterramexico05 xterramexico05 is offline
Tech Enthusiast
2005 Xterra
 
Join Date: Oct 2008
Posts: 328
Default

i am not a mechanic but - some transmissions on some cars are controled by the ecu. meaning that they adjust how the driver is driving the car. some husbands have complaint about not wanting to drive their wifes cars because their auto-shifting points bother them.

so would it help your problem to re-set the ecu and re-teach the ecu your shifting points????
Reply With Quote
  #5  
Old 06-11-2009, 05:40 PM
streamcast streamcast is offline
Master Enthusiast
1997 Altima
1995 Sentra
1995 Nissan sentra
 
Join Date: Jan 2009
Location: CANADA
Age: 49
Posts: 1,214
Default

Also the code is being set because of the gearset change. The vss is read of the abs wheel speed sensors. If you change the gear set that means they are probably turning at different rates and the ecm cannot calculate it properly.
Reply With Quote
  #6  
Old 10-24-2012, 01:21 AM
350zGReddy 350zGReddy is offline
Registered User
2003 350Z
 
Join Date: Oct 2012
Posts: 1
Default

Hello, I have this same problem, anyone know how to get it repaired? please help my mechanics are not the solution and no longer to do...
Reply With Quote
Reply

Bookmarks

Tags
problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:10 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.