Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
2007 SL 120k miles ABS system Failure Forums > > 2007 SL 120k miles ABS system Failure 2007 SL 120k miles ABS system Failure
Forgot Password? Join Us!


Maxima Nissan Maxima Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 04-20-2022, 06:24 PM
chablis chablis is offline
Registered User
2007 Maxima
 
Join Date: Apr 2022
Posts: 2
Default 2007 SL 120k miles ABS system Failure

I have had my 07 Maxima into the dealer recently and wanted to summarize the issues.

2 Years back ABS light came on.

Dealer wanted $3000 to fix it so I have been driving without ABS.

One month back the car started to experience intermittent acceleartyions issues. For example trying to get on expressway, the car would not get above 35-40 even with the RPM at 4k

I tool to my dealer and the car had no codes.

They said to take to nissan as they do not work on CVT.

$500 later, the dealer ran some codes and looked up the NTB.

-ABS controller is not responding across the CAN.
-Speed sensors need to be replaced.
-No issues with CVT

Cost to fix $2500 on top of the $500.

I spent the easter weekend replacing the ABS module and speed sensors

ABS module was hard to find for the 07 that is same module #.

47660 ZK40A is common but not the 47660 ZK30A

Finally found a donar vehicle after 4 hrs.

Front sensors where easy.

Rear I took recomended precautions, but still snapped one bolt. Will figure out the fix latter
Reply With Quote
  #2  
Old 04-20-2022, 06:29 PM
chablis chablis is offline
Registered User
2007 Maxima
 
Join Date: Apr 2022
Posts: 2
Default RE

So after 8 hrs if work, I still have following

From Key on I have Slip and VDC Off lights

After moving 10-15 ft the ABS and brake light come on

For codes, recall I had no codes before with hand scan tool

Now I have U1000, and C1124 and C1155 with hand scan tool

Scan tool says C1124 is Shaft speed signal, but online it says brake fluid level. The brake lines where bleed after module was replaced and the fluid is full

C1155 says Front wheel sensor so I need to recheck

So now for question.

I assume no need to flash the ABS module or clear the U1000.

Should I go back to the dealer to have them rescan, or should I tear the nuckle down and do a deep cleaning.

I wish I had an alternative to the dealer as they clearly have no experience with this issue.

I would be fine to getting back to no ABS, but the lack of acceleration is something I need to resolve.
Reply With Quote
Reply

Tags
120k, abs, failure, miles, system

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:52 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.