Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
99 SE - blower fan runs at the slowest speed in all settings Forums > > 99 SE - blower fan runs at the slowest speed in all settings 99 SE - blower fan runs at the slowest speed in all settings
Forgot Password? Join Us!


Maxima Nissan Maxima Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 11-27-2012, 06:37 PM
milli milli is offline
Registered User
1999 Maxima
 
Join Date: Sep 2010
Posts: 6
Default 99 SE - blower fan runs at the slowest speed in all settings

Hi,

Since yesterday, the blower fan is running very slowly(probably @ setting 1 speed) at all settings. I searched and see it could be the resistor. But then I also read it is applicable only for manual control. For automatic control(which I have), it would be the fan control amplifier.

Can someone confirm if it is the fan control amplifier or the fan itself which I need to change? Also can you provide pointers to "how to" on them. Much appreciated. Thx.
Reply With Quote
  #2  
Old 11-27-2012, 08:36 PM
NissanTech's Avatar
NissanTech NissanTech is offline
Super Moderator
2004 Xterra
 
Join Date: Jun 2005
Location: California
Age: 51
Posts: 12,463
Default

It does sounds like the fan control amplifier. The price for the amp is around $75 and you probably can find the part on AutoZone or any other autoparts.

The instruction to replaced the amp are here: 2000-2003 Nissan Maxima Blower Motor Amplifier/Resistor Replacement Procedure | Nissanhelp.com

The instructions are for the 2000-2003 Maxima, but removing the glove box is the same, the only difference is that the Amp is in front instead of of the bottom of the blower motor.

99 SE - blower fan runs at the slowest speed in all settings-capture-png
Attached Thumbnails
99 SE - blower fan runs at the slowest speed in all settings-capture-png  
__________________
Need A Repair Shop?
Find local automotive repair shops in your area.
AutoCodes.com Shops
Reply With Quote
  #3  
Old 11-27-2012, 09:51 PM
milli milli is offline
Registered User
1999 Maxima
 
Join Date: Sep 2010
Posts: 6
Default

Thanks for your response. Would bad relay cause this issue? Just wanted to check.
Reply With Quote
  #4  
Old 11-29-2012, 01:43 PM
milli milli is offline
Registered User
1999 Maxima
 
Join Date: Sep 2010
Posts: 6
Default

Thanks. Replacing the fan control amp worked. But had to buy it from the dealer.
Reply With Quote
  #5  
Old 05-07-2021, 08:07 AM
Redhead770 Redhead770 is offline
Registered User
1999 Maxima
 
Join Date: May 2021
Posts: 1
Default

I'm having a similar issue with my 99 maxima, I replaced the resistor card and blower motor and when I turn the fan speed from 1 to 4 you can hear the fan spinning up but hardly nothing comes out of the vents. I was wondering if it could be the actual HVAC controls or a fuse of some kind? Any help with this would be greatly appreciated.
Reply With Quote
Reply

Tags
blower, fan, runs, settings, slowest, speed

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:39 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2023 DragonByte Technologies Ltd.