Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
07 Frontier won't enter diagnostic mode. Forums > > 07 Frontier won't enter diagnostic mode. 07 Frontier won't enter diagnostic mode.
Forgot Password? Join Us!


Frontier Nissan Frontier/HB/Truck Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 08-24-2017, 07:34 AM
NISFRONT NISFRONT is offline
Registered User
2007 Frontier Crew Cab
 
Join Date: Aug 2017
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default 07 Frontier won't enter diagnostic mode.

2007 2WD spark plugs about a week ago and while I was doing that job, I thought it would be a good idea to clean the throttle body since I had to take the duct loose to remove the intake plenum anyway. I probably don't have to tell you that cleaning the throttle body was a dumb idea. I should have read up on it before I did it, but I always read the instructions after I screw up instead of before. Anyway the SES (CEL or MIL whatever you like to call it) light came on when I was driving it the other day. I took it to Advance Auto Parts and they put their OBDII scanner on it and it spit out P0507. I came home and started doing research and found the procedure for Idle Air Volume relearn without Consult II. I've tried a number of times to do this procedure, but when I get to the final step, the light only blinks 5 times. I have the same problem when I try to enter diagnostic mode. It only blinks 5 times. I tried disconnecting the battery for 15 minutes, but that didn't do any good. I can clear the code fine, but the SES light will always return. Last night I disconnected the battery when I got home from work and I am going to see if that helped at all. I will post the results later. I live in NC and we have annual vehicle inspections and they won't pass it if you have an active SES light. My truck is due inspection the end of this month so I need to get this problem resolved. Anyone have any ideas on why it won't go into diagnostic mode and/or how to fix this problem I seem to have created?



Thank you,
NISFRONT

Last edited by NissanTech; 08-25-2017 at 10:54 AM. Reason: Removed links
Reply With Quote
  #2  
Old 08-25-2017, 10:57 AM
NissanTech's Avatar
NissanTech NissanTech is offline
Super Moderator
2004 Xterra
 
Join Date: Jun 2005
Location: California
Age: 47
Posts: 12,168
Thanks: 473
Thanked 589 Times in 528 Posts
Default

Without the CONSULT is a bit difficult (sometimes even with the CONSULT). Only thing I can suggest is to turn the ignition ON and OFF several times (over 10 times) and then try to reset the idle.
__________________
Need A Repair Shop?
Find local automotive repair shops in your area.
AutoCodes.com Shops
Reply With Quote
  #3  
Old 08-25-2017, 11:01 AM
NISFRONT NISFRONT is offline
Registered User
2007 Frontier Crew Cab
 
Join Date: Aug 2017
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thank you for the tip. I will give it a try when I get off work tonight.
Reply With Quote
Reply

Bookmarks

Tags
diagnostic, enter, frontier, mode

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 10:57 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.