Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
1998 Nissan Altima needs help Forums > > 1998 Nissan Altima needs help 1998 Nissan Altima needs help
Forgot Password? Join Us!


Forum Feedback, Suggestions and General Usage Nissanhelp.com feedback, suggestions and general usage information. How to download manuals or post questions.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-04-2021, 08:50 AM
TLMFL TLMFL is offline
Registered User
1998 Altima SE-R
2000 Frontier King Cab
1998 Nissan Altima
 
Join Date: Dec 2020
Location: Tampa, Fl.
Posts: 6
Default 1998 Nissan Altima needs help

-Hello Everyone,

I have a 1998 Nissan Altima 2.4L SOHC that stalls out after 2 or 3 minutes from starting.
If I turn the key to start the car it will try and try to start but never quite get there.
If I turn the key to the on position, lights come on on the dash and the fuel pump starts.
When the fuel pump stops, I turn the key off, I do this 3 times then I can start the car no problem.
Iím at a loss of what to do, the car acts like itís not getting gas to stay running after using up
what gas has been pushed to the rail.

I checked/tested all the fuses under the hood and under the dash on the driver side.
A friend flushed the engine for me, refilled and burped it.
I replaced the Thermostat, after the engine flush before It was refilled.
I replaced all the holes and clamps, all are tight.
I replaced the Distributor cap, rotor, and wires.
Plugs were replaced 2 months ago but I cleaned and re-spaced them.
I replaced the fuel pressure regulator. The fuel pump and filter in the tank. The fuel filter canister on the
fire wall and checked the pressure in all these places. All are good.
I cleaned the throttle body 3 or 4 times now.
I replaced the EGR, EGR-C/BPT valves and still no start.
I keep going back and checking relays and fuses to make sure I didnít blow something.

Iím at a loss. I don't know what to do next, the car is still acting like itís not getting gas to stay running.

If anyone can help I would greatly appreciate it.
Reply With Quote
Reply

Tags
altima, nissan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:23 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.