Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Armada Brake Problems. Is the dealer telling the truth? Forums > > Armada Brake Problems. Is the dealer telling the truth? Armada Brake Problems. Is the dealer telling the truth?
Forgot Password? Join Us!


Armada Nissan Armada Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 04-21-2011, 01:57 PM
jangeador
Guest
 
Posts: n/a
Default Armada Brake Problems. Is the dealer telling the truth?

Hello, I am having a problem that seems to be very common with the Armadas. Sometimes the brake pedal will rattle and make a strange grinding noise and the car feels as if it would not break.

I took it to the dealer and they replaced the brake booster and that did not help, after reading the internet I came across the NTB06-040 2004 2006 TITAN AND ARMADA; ABS AND/OR BRAKE WARNING LIGHT ON WITH DTC C1179.

I referred the dealer to such Technical Bulletin and they say that they cannot get the code, and that the maintenance outlined in the bulletin was done as part of the brake booster replacement.

Is the dealer telling me the truth or are these things unrelated?

Thanks,

jangeador.
Reply With Quote
  #2  
Old 04-28-2011, 04:03 AM
Boland01 Boland01 is offline
Enthusiast
2009 Altima
2005 Armada
2005 Armada Le
 
Join Date: Jan 2008
Posts: 66
Default

We had a similar incident with our 2005 LE. No brakes and the ABS grinding. When you turned the car off it would reset and work fine. Turned out ours did set a code and it was a sensor in the brake booster. The Dealership fixed ($760.00) it and we haven't had an issue since. That was about 4 months ago.
I can't understand why would Nissan not have a fail safe designed into the vehicle if the sensor fails and why would they not have designed the sensor so it was not an integral part of the brake booster. Poor design and it going to cause a wreck or something worse someday.
Reply With Quote
  #3  
Old 08-03-2011, 05:39 AM
surveycop
Guest
 
Posts: n/a
Default

I bought a 2006 LE a year ago and had about three incidents of this problem. The brakes worked at a reduced power, so I could stop each time. Luckily, I wasn't traveling fast and not in traffic when they occured. When I had the Armada in for another service, the dealer worked on the brakes per the TSB. I didn't ask if a code was set, but since then, I haven't had any more problems with reduced or no brake power. Occasionally the brakes will make a grinding noise with full stopping power. I assume this is to "clean" the pads or disc, but I don't have a lot of brake experience, so that may not be the case. Good luck with solving the problem.
Reply With Quote
  #4  
Old 08-03-2011, 05:45 AM
Boland01 Boland01 is offline
Enthusiast
2009 Altima
2005 Armada
2005 Armada Le
 
Join Date: Jan 2008
Posts: 66
Default

The grinding noise is defintely NOT the brakes cleaning themselves. This is not normal. It sounds like your ABS may be cycling on and off. Unless you are braking very hard (Locking the wheels) the ABS should not be kicking in.

Brakes are too critical of an item not to have work properly each time.
Reply With Quote
  #5  
Old 08-03-2011, 12:12 PM
surveycop
Guest
 
Posts: n/a
Default

I appreciate your response. I'll check it out. The noise I'm hearing doesn't sound or feel like the ABS when it operates under threshold braking. That means its either an ABS problem or another problem with the braking system. Unfortunately, it doesn't occur often, so I can't replicate it for the dealer. We'll see how it turns out.
Reply With Quote
  #6  
Old 08-08-2011, 09:57 AM
cootye
Guest
 
Posts: n/a
Default Same happened to me Yesterday Armada Brake Problem

I was driving along and the Brake light came on and when I pressed on the brake an awful spongy crunching noise. Brakes don't work. This has happened to mne before. I brought it to a brake place only to be told nothing was wrong. Each time I had to turn off the vehicle and turn it back on to reset the brake light. I would like to here from other people this has happened to. cootye at aol dot com. I had my family in the car with me when it happened and it could have been alot worse. This should be recalled.
Reply With Quote
  #7  
Old 10-03-2011, 01:44 AM
JAtchley80
Guest
 
Posts: n/a
Default

I am also having is issue as well. They replaced the sensor and it happened again about a week ago. Almost a year after replacing it.
Reply With Quote
  #8  
Old 10-11-2011, 11:59 AM
06 armada
Guest
 
Posts: n/a
Default

I have an 06 ARMADA we were driving it a week ago, when we came to a stop sign and the brakes failed. It made a grinding noise, brake lights were on but no brakes very scary for us, and my 4yr old and 8 yr old were freaked out.
I have FILED a complaint with The National Highway Traffic Safety, but I dont know if anything will be done. They also have several complaints regarding this same problem going back to 2008. - BUT NO RECALL SO FAR - I think going to FOX news or any other news broadcasting channel might help with invastigating this issue. Maybe a Recall can be done.
Reply With Quote
  #9  
Old 10-12-2011, 07:58 AM
wkocken
Guest
 
Posts: n/a
Default

I have had this happen 3 times to my '04 Armada. It has always happened the first time applying the brakes after starting the engine. ( I don't recall if it ever happens when stopping after backing out of the driveway or parking spot, hmm. ) Fortunately, 99.9% of the time my first stop is at low speed. Turning off the engine and restarting makes the problem go away.
Reply With Quote
  #10  
Old 10-13-2011, 12:06 PM
aamaak
Guest
 
Posts: n/a
Default

I have Armada 2006
i am in Saudi Arabia
i have the same prblem 2 times
i need to know how to solve the problem
please advcie
Reply With Quote
  #11  
Old 10-13-2011, 12:08 PM
aamaak
Guest
 
Posts: n/a
Default


I have Armada 2006
I am in Saudi Arabia
I have the same problem 2 times
I need to know how to solve the problem
please advice

Reply With Quote
  #12  
Old 12-02-2011, 12:19 PM
amber78
Guest
 
Posts: n/a
Default Braking problems in my 2006 Armada

I purchased my Armada nearly 2 years ago from a local dealer use. Almost 3 weeks to the day after my purchase I had my first experience with my brakes failing.. My VDC Off/Slip/Brake lights came on in my vehicle. When I attempted to stop, I had virtually 20% of breaking power. My 2 daughters were in the vehicle with me as we almost slammed into the back of a semi truck. I cannot tell you just how terrifying this experience was the first time.. Not to mention the nearly 30 times that it has happened over the course of 2 years. I have had my vehicle in the shop numerous times to find out what the problem is and everytime I am looked at like I am crazy. Like I dont know what I am talking about. Well I can assure you, I know exactly what I am talking about, and I am appauled that Nissan would make a vehicle with brake pads that are TOO SMALL for one, and to read over a hundred posts on Edmunds that I am not the only person having this problem is obsurd. I have printed off every post from ever testimony and fully intend to seek legal councel. I paid alot of money for my vehicle and Nissan should make it right. I called my Nissan dealership today to check on the price for a brake booster, which is what some people have found to fix the problem... $800... Who has $800 just sitting around waiting to dump it into your vehicle that Nissan should be paying to replace in the first place. My suggestion is, get off your high horse and fix our vehicles.. My voice will be heard....
Reply With Quote
  #13  
Old 12-02-2011, 01:07 PM
Boland01 Boland01 is offline
Enthusiast
2009 Altima
2005 Armada
2005 Armada Le
 
Join Date: Jan 2008
Posts: 66
Default

We had the $800 brake booster-delta sensor fixed done last February. Two days ago our Armada once again lost braking power and had the brake shudder while my wife was driving it. At this point I'm debating do I take it back to the dealer again or just sell it. There is also a class action lawsuit being put together out there. Go to Nissan Armada Clubs forum. You can find it in there.
Reply With Quote
  #14  
Old 12-02-2011, 01:11 PM
amber78
Guest
 
Posts: n/a
Default

Thank you very much for your reply. Im going to the website now
Reply With Quote
  #15  
Old 12-07-2011, 07:43 PM
Jrust
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by Boland01 View Post
We had the $800 brake booster-delta sensor fixed done last February. Two days ago our Armada once again lost braking power and had the brake shudder while my wife was driving it. At this point I'm debating do I take it back to the dealer again or just sell it. There is also a class action lawsuit being put together out there. Go to Nissan Armada Clubs forum. You can find it in there.
Just brought my 2005 armada home from the dealer two days ago after 3 serious bouts with the brakes going out and shaking/grinding noise. Nearing home, it did it again. I wanted this car to last for several years. Now I just don't trust it. Please tell me more about the class action. I can't seem to find it. Thanks.
Reply With Quote
Reply

Bookmarks

Tags
armada, brake, dealer, problems, telling, truth

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:45 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.