Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
2000 altima guages, tach, speedometer and cruise stop working Forums > > 2000 altima guages, tach, speedometer and cruise stop working 2000 altima guages, tach, speedometer and cruise stop working
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 06-29-2008, 07:34 AM
kout
Guest
 
Posts: n/a
Default 2000 altima guages, tach, speedometer and cruise stop working

Just purchased a used 2000 Altima GXE and now all the dash guages stop working at the same time. Temp, tach, speedometer, odometer cruise control. I can turn off the car and restart and then all is well for a while then same problem. I noticed it while I had the cruise on and then it went off along with everything else on the dash. Even the odometer. Any one have a way of testing and figuring this one out? Thanks, John
Reply With Quote
  #2  
Old 06-29-2008, 09:18 AM
vpnavy's Avatar
vpnavy vpnavy is offline
Tech Enthusiast
2015 Rogue
 
Join Date: Mar 2007
Location: York, PA
Posts: 2,138
Default

Until a Specialist resplies...It could be a number of things.

Check the following:

1. Check the Main Harness Ground (see attachment) since it affects all gauges mentioned.

2. Check for a loose fuse (both cabin and engine compartment).

3. Make sure you battery cables are clean and tight.

4. Reach behind the Instrument Cluster and make sure the connector is not loose.
Attached Thumbnails
2000 altima guages, tach, speedometer and cruise stop working-1-jpg  
__________________
SHOW YOUR SUPPORT!
Subscribe

FIND OUT WHAT YOUR REPAIR SHOULD COST?
Repair Cost Estimator

BUY NISSAN ACCESSORIES!
Nissanhelp Store
Reply With Quote
  #3  
Old 04-19-2011, 10:01 AM
ddkegel71 ddkegel71 is offline
Registered User
2000 Altima
 
Join Date: Apr 2011
Posts: 1
Default

my AC goes out too because there is no power, meaning the light goes off with the speedpmeter etc...
Reply With Quote
Reply

Bookmarks

Tags
2000, altima, cruise, guages, speedometer, stop, tach, working

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 10:13 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.