Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Camshaft Sensor replaced but light still comes on? Forums > > Camshaft Sensor replaced but light still comes on? Camshaft Sensor replaced but light still comes on?
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 09-28-2018, 06:36 AM
Alleria Alleria is offline
Registered User
2008 Altima Hybrid
 
Join Date: Sep 2018
Posts: 1
Default Camshaft Sensor replaced but light still comes on?

I recently replaced the camshaft sensor on my 2008 Nissan Altima hybrid but now every so often the master hybrid light will come up on the dashboard and when I run the scanner through it the same P0340 code comes up. If I don't clear the code, my car will not get full power and idle hard, I'll have accelerating issues and at one point my car stalled getting onto the fwy. I'm not sure what to do? I just paid to have it replaced but I feel like it's running the same as before if not worse now. Can someone please help?
Reply With Quote
Reply

Bookmarks

Tags
camshaft, light, replaced, sensor

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 03:54 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.