Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
code po500 and code po136 Forums > > code po500 and code po136 code po500 and code po136
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 06-01-2007, 08:12 AM
jeanie
Guest
 
Posts: n/a
Default code po500 and code po136

Hi People...........I have a 1996 nissan altima gxe. The speedometer and odometer work every so often. I have replaced the vss and checked the wiring. When the speedometer and odometer do work, the check engine light comes on and sets codes po500 and po136.....any help will be appreciated......:)
Reply With Quote
  #2  
Old 06-01-2007, 08:23 AM
NissanTech's Avatar
NissanTech NissanTech is offline
Super Moderator
2004 Xterra
 
Join Date: Jun 2005
Location: California
Age: 48
Posts: 12,258
Default

Hello

Check the screws behind the speedometer head. The screws are used as connectors for the speedo head. Sometimes the screws come loose and set code P0500.

The other code P0136 is for the rear O2 sensor, and you most likely have to replaced the sensor to repair the problem.
__________________
Need A Repair Shop?
Find local automotive repair shops in your area.
AutoCodes.com Shops
Reply With Quote
  #3  
Old 08-08-2019, 04:58 PM
rapaulino rapaulino is offline
Registered User
1999 Altima Sedan
 
Join Date: Jul 2019
Posts: 2
Default Intermittent Speedometer on a 1999 Altima (error code P0500)

Hi everyone. I have the same problem with my 1999 altima. The VSS has been replaced 3 times and the problem still present. The screws adjustment might the solution since the problem is intermittent (comes and goes). I would like to know if anyone solve this problem by tightening the screws on the instrument cluster.
Reply With Quote
  #4  
Old 08-08-2019, 10:51 PM
smj999smj's Avatar
smj999smj smj999smj is offline
Master Enthusiast
2006 Pathfinder
2003 Frontier King Cab
2003 Frontier KC SVE 4x4
 
Join Date: Jun 2012
Location: Prospect, VA
Posts: 1,785
Default

Nissan had a lot of problems in the mid to late 90s with the threaded inserts in the back of the speedo head (the ones that the mounting bolts that contact the printed circuit thread into) developing cracks, which caused the bolts to loosen-up at the time. I worked with a Nissan service rep on a similar issue on a 1995 Sentra that would throw the P0500 code on a somewhat regular basis. He brought out a Japanese engineer who literally cut right through the main harness so he could take the instrument cluster/harness connectors and about 8" of wiring harness with him for testing. Of course, he installed a new cluster and harness connectors and soldered all of the wires on the vehicle. Tightening the screws can fix the problem for a given amount of time; just what that amount of time is, one never knows! It could be days, months...years! The proper fix is to replace the speedometer head with a new one. As the years go by and many of these speedo heads get discontinued, this gets harder to do.
Reply With Quote
Reply

Bookmarks

Tags
code, po136, po500

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 01:18 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.