Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
02 Altima 2.5s Engine Oil light flashing Forums > > 02 Altima 2.5s Engine Oil light flashing 02 Altima 2.5s Engine Oil light flashing
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 09-19-2013, 02:19 PM
DallasM DallasM is offline
Registered User
2002 Altima Sedan
 
Join Date: Sep 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default 02 Altima 2.5s Engine Oil light flashing

I have an 02 Altima 2.5s that here recently had the engine oil light start flashing on/off. Long story short the car was in the shop originally for a misfire which turned into spark plug replacement, 2 coil packs replaced, PVC valve, valve cover and valve cover gasket, head gasket, and intake manifold gasket replacement. Also they changed the oil then. Got all that squared away and now the engine oil light is flashing. It only does it when my foot is off the accelerator and it hits about 35mph (1200rpm) and lower or at a complete stop. Once I push the accelerator it goes off and stays off. Also it don't start doing it until I have driven a good 10+ miles. My mechanic has taken the lower oil pan out and cleaned the oil tube that pulls the oil up in the motor (does that sound right?). Also every oil passage way from the lower oil pan up to the head has been cleaned to ensure there is nothing restricting the oil flow. He also put a new head on it for some reason as well as replaced timing cover parts. Oil was then changed again just to ensure that there was nothing in the oil to clog the passage ways and given back to me, but to no avail it is still doing it. Oil level is full, there are no leaks, and it is not burning any oil. Any ideas?
Reply With Quote
  #2  
Old 09-19-2013, 03:51 PM
G47
Guest
 
Posts: n/a
Default

has the oil pressure switch been replaced? it could be a bad oil pressure switch
Reply With Quote
  #3  
Old 09-19-2013, 05:00 PM
DallasM DallasM is offline
Registered User
2002 Altima Sedan
 
Join Date: Sep 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I asked my mechanic that today and he told me that he pulled the oil sending unit and put a rag in it to see if there was pressure and oil shot out so it was good.
Reply With Quote
Reply

Bookmarks

Tags
25s, altima, engine, flashing, light, oil

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:41 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.