Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
05 Altima autolamps Forums > > 05 Altima autolamps 05 Altima autolamps
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 10-27-2012, 06:53 PM
Soapmyster Soapmyster is offline
Tech Enthusiast
2005 Altima
2005 Altima
 
Join Date: Oct 2012
Location: Oriskany
Posts: 180
Cool 05 Altima autolamps

can anyone tell me if the 2005 Nissan Altima is prewired for autolamps. I found it is prewired for foglamps and have installed factory foglamps.
I am waiting on the turn signal stalk. the one I ordered has the autolamp and foglamp switches.
We really want autolamps also but dont know if there is a way to utilize the factory setup.
Thank you in advance
Reply With Quote
  #2  
Old 10-28-2012, 01:22 PM
bennyb53's Avatar
bennyb53 bennyb53 is offline
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 2,104
Default

my 02 Altima is equipped with auto light system (tho i don't use it) so i can't imagine your 05 is not. refer to Lighting System manual page LT-44. all manuals are found in Knowledgebase section. you owner's manual will have reference also.
Reply With Quote
  #3  
Old 10-28-2012, 05:51 PM
Soapmyster Soapmyster is offline
Tech Enthusiast
2005 Altima
2005 Altima
 
Join Date: Oct 2012
Location: Oriskany
Posts: 180
Default

thank you for your response. I pulled the cover off the dash where the sunload sensor goes but there is no 3 pin plug under there. unless it is tied up in the harness in the dash. has anyone ever looked into this?
Reply With Quote
  #4  
Old 05-25-2015, 07:06 PM
Soapmyster Soapmyster is offline
Tech Enthusiast
2005 Altima
2005 Altima
 
Join Date: Oct 2012
Location: Oriskany
Posts: 180
Default

Well guys back at this again.
I just bought another altima.
This one is a 2003 and I did the same thing as the 2005. I bought the stalk for the autolamps and foglamps.
I added the foglamps and they work fine on both.
There is a difference though in the autolamps.
On the 2005 the auto position on the combination switch acts like the off position.
on the 2003 it turns on the parking and headlamps, foglamps also if on.
So this difference got me wondering again.
The diagram is different for the 03 and 05.
I wonder if the 2003 has the plug for the sunload sensor because of the fact that the lamps do function in the auto position on the stalk.
I mainly want them because I am so used to having the features on my other cars. Once you are used to them it is nice to have.
If I cannot have them factory though I would not make them.
Thanks all
Reply With Quote
  #5  
Old 06-15-2015, 09:47 AM
Soapmyster Soapmyster is offline
Tech Enthusiast
2005 Altima
2005 Altima
 
Join Date: Oct 2012
Location: Oriskany
Posts: 180
Default

Ok so some good news to share.
I did the provision on the 2003 and will try it on the 2005.
The provision is already in the BCM so once all is complete it should already work.
I replaced the stalk with a auto and fog lamp options
I bought a sunload sensor and the trim part. Shares with the security light.
I then pulled a pigtail and pinned it into the bcm. There are 3 wires,
bcm + output
Bcm - output
sunload signal
1 wire taps into the brown plug at the bcm
2 wires tap into one of the white plugs at the bcm.
Once I added the pigtail from the bcm to the sunload sensor it works perfectly.
I dont really want DRLs but the autolamps work nicely. Never have to turn the lights
on and off.
If anyone is interested I would be happy to share more specifics as to the schematic.
I might add that I used the diagram from this site and it was right on. Thanks
Reply With Quote
  #6  
Old 10-02-2015, 07:20 PM
Soapmyster Soapmyster is offline
Tech Enthusiast
2005 Altima
2005 Altima
 
Join Date: Oct 2012
Location: Oriskany
Posts: 180
Default

Ok Is there anyone on here that is familiar with the BCM that is in the 2005 Altima.
It is different from the 2002-2004, quite different actually.
I am really scratching my head at the moment and dont give up easy.
Plain and simple the 5v output from the BCM to the sunload sensor is not present.
I dont know if it is because the feature bank is disabled or if it is because there is possibly a wire not present from the combination switch.
I cant be the only one out there that added autolamps
Reply With Quote
  #7  
Old 10-03-2015, 04:33 AM
mpe235's Avatar
mpe235 mpe235 is offline
Moderator
2015 Rogue
 
Join Date: Jun 2006
Location: New York
Posts: 5,565
Default

Quote:
Originally Posted by Soapmyster View Post
Ok Is there anyone on here that is familiar with the BCM that is in the 2005 Altima.
It is different from the 2002-2004, quite different actually.
I am really scratching my head at the moment and dont give up easy.
Plain and simple the 5v output from the BCM to the sunload sensor is not present.
I dont know if it is because the feature bank is disabled or if it is because there is possibly a wire not present from the combination switch.
I cant be the only one out there that added autolamps
It may be the configuration in the bcm. You can check it with some scan tools. It can be configured for with or without auto lamps.
__________________
Nissan Master certified Technician
Hybrid and GTR certified
EV certified
ASE Master Certified.
Reply With Quote
  #8  
Old 10-03-2015, 06:05 PM
Soapmyster Soapmyster is offline
Tech Enthusiast
2005 Altima
2005 Altima
 
Join Date: Oct 2012
Location: Oriskany
Posts: 180
Default

I am thinking that is the problem.
My 03 was already active and worked fine.
the 05 does not work.
I dont know what kind of scantool would change the configuration other than
going to the dealer.
I know my determinator was useless
Reply With Quote
  #9  
Old 10-04-2015, 08:53 AM
mpe235's Avatar
mpe235 mpe235 is offline
Moderator
2015 Rogue
 
Join Date: Jun 2006
Location: New York
Posts: 5,565
Default

Quote:
Originally Posted by Soapmyster View Post
I am thinking that is the problem.
My 03 was already active and worked fine.
the 05 does not work.
I dont know what kind of scantool would change the configuration other than
going to the dealer.
I know my determinator was useless
Snap on solus, modis, Autel maxidas, should do it.
Most of the shop level tools should have that capability.
Reply With Quote
  #10  
Old 10-05-2015, 09:20 PM
Soapmyster Soapmyster is offline
Tech Enthusiast
2005 Altima
2005 Altima
 
Join Date: Oct 2012
Location: Oriskany
Posts: 180
Default

I have A lAUNCH x-431. It seems quite like the consult2. I see how to change the modes for the feature but dont see how to change the configuration. I hope I am just missing something. Any insight?
Reply With Quote
  #11  
Old 09-19-2016, 07:47 PM
Soapmyster Soapmyster is offline
Tech Enthusiast
2005 Altima
2005 Altima
 
Join Date: Oct 2012
Location: Oriskany
Posts: 180
Default

Well guys still banging my head on this one.
No matter what scantool I hook up to the 05 altima there is no autolamp setting in the bcm or IPDM.
I am at such a loss. I just dont understand what I am missing. I love the feature on my 03 but cannot get it to work in my 05. Everything is there for it to work but I cannot enable it in the BCM.
Reply With Quote
  #12  
Old 03-03-2017, 06:14 PM
Soapmyster Soapmyster is offline
Tech Enthusiast
2005 Altima
2005 Altima
 
Join Date: Oct 2012
Location: Oriskany
Posts: 180
Default

YAY success finally. Took a few years but I finally got the autolamps option working on my 05 Altima.
Plain and simple the option did not exist in the BCM (no way to program it)
I replaced the BCM from a donor that had the option.
I then had to get the keys reprogrammed.
Voila. it works excellent.
I actually acquired a few other options at the same time.
I love our Altima's. what a nice feature the autolamps are
Reply With Quote
Reply

Bookmarks

Tags
altima, autolamps

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 01:31 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.