Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
2005 Nissan Altima Windshield Wipers Not Working Forums > > 2005 Nissan Altima Windshield Wipers Not Working 2005 Nissan Altima Windshield Wipers Not Working
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-19-2011, 09:49 PM
keithsmithtx1
Guest
 
Posts: n/a
Default 2005 Nissan Altima Windshield Wipers Not Working

Could not find this information myself, figured it out, so I thought I'd post in case someone else needs it.

Windshield was covered in ice. Wife turned on wipers but they did not move and she did not turn them off. After ice melted, wipers did not work. Could not hear motor. Good news, turned out to be the fuse.

Other posts said to 1) check fuse 2) check switch 3) check motor. Most fuses are not labeled. Could not find a fuse diagram online. Posting pics to show where fuse is.

There are two fuse boxes under the hood. The one near the windshield wiper fluid reservoir (on left) holds the 20 amp fuse (yellow) for wiper motor. Remove cover, two tabs on side hold the fuse box in. In attached photo, the fuse is pulled and belongs in the empty slot 3rd from right on top row.
Attached Thumbnails
2005 Nissan Altima Windshield Wipers Not Working-img00034-20110218-1819-jpg   2005 Nissan Altima Windshield Wipers Not Working-img00033-20110218-1818-jpg   2005 Nissan Altima Windshield Wipers Not Working-img00032-20110218-1816-jpg  
Reply With Quote
  #2  
Old 07-25-2011, 07:34 PM
BBetz
Guest
 
Posts: n/a
Default Thanks!

Thanks for the info, you're a life saver. I couldn't find where that fuse was anywhere. You think they would list it in the owner's manual.
Reply With Quote
  #3  
Old 12-15-2011, 09:12 AM
ITALIAN926 ITALIAN926 is offline
Registered User
2003 Altima
2005 Altima
 
Join Date: Dec 2011
Posts: 1
Default Thank you !

Signed up just to thank the OP. Made this fix just a little quicker for me. I knew it was probably a fuse but having the exact co-ordinates was nice.

As I read this post, it was as if I wrote it. Wife also turned on wipers when they were iced over. Women.
Reply With Quote
  #4  
Old 10-29-2012, 10:07 AM
Sami F Sami F is offline
Registered User
2005 Altima
 
Join Date: Oct 2012
Posts: 1
Default

I also signed up so that I could say thanks, this has saved me a lot of time and trouble.
Reply With Quote
  #5  
Old 12-18-2012, 06:13 AM
[email protected] Darn_Fit@hotmail.com is offline
Registered User
2005 Altima
 
Join Date: Dec 2012
Posts: 1
Default Thank You for the Info

One cold winter morning I turned on the windshield wipers on our 2005 Nissan, Altima. The windshield wipers did not work as they were frozen to the windshild. After I broke free the wipers from the windshield, the wipers did not work. I was unable to hear the windshield wiper moter.

After viewing your posting and your 3 attachments/photos of how to replace the fuse, I followed your "excellent" instructions and repaired the windshied wiper blades myself.

Thank you very much for posting the above information.......L
Reply With Quote
  #6  
Old 01-09-2013, 12:36 PM
mdavis mdavis is offline
Registered User
2005 Altima
 
Join Date: Jan 2013
Posts: 1
Default Repairing wipers on 2005 Altima

Thanks so much for the post. It was a quick easy fix for me because of the great info you left
Reply With Quote
  #7  
Old 02-14-2013, 07:38 AM
Timaeus Timaeus is offline
Registered User
2005 Altima Sedan
 
Join Date: Feb 2013
Posts: 1
Default

Thanks for the pictures this fix worked for me too.
Reply With Quote
  #8  
Old 06-13-2013, 05:18 PM
Letty4jesus Letty4jesus is offline
Registered User
2002 Altima Sedan
 
Join Date: Jun 2013
Posts: 1
Default Wiper problems

Thanks I hope is the same for my Altima 2002 because my wipers won't do anything ? Will try and let you know !
Reply With Quote
  #9  
Old 12-30-2016, 06:47 AM
RDA RDA is offline
Registered User
2006 Murano
 
Join Date: Dec 2016
Posts: 1
Default

My wipers cycled about 3 times this snowy morning and then stopped. No movement, no sound from motor. I first checked the fuse in the box near the washer fluid bottle, (mine is a green 30 amp). It is OK. Checked fuse with multitester just to be sure. It's fine. Hmm...tried wipers again, this time without engine running and yes,I CAN hear the wiper motor cycling. Changed speed of IM wipers to be sure that is what I am hearing...yes, that is the wiper motor I hear. OK, wiper blade linkage must have broken or come off. Removed cover on D/S over wiper motor. Reached inside with right hand while moving wiper arms with left. Yes, Linkage between motor and arms was off. Popped linkage back onto shaft (a little too easily, shouldn't there be some kind of clip securing it there? Problem fixed, wipers work fine now but as easily as I put it back on I am concerned it will just pop off again. Have since done a lot of searching online and found these repair clips: x2 NICKEL ONE WIPER WORKING? WINDSCREEN WIPER MOTOR LINKAGE LINK REPAIR CLIP KIT | eBay
Should be here next week, we'll see if they work out or not.

Last edited by RDA; 12-30-2016 at 09:44 AM. Reason: edited as repair progressed
Reply With Quote
  #10  
Old 01-13-2018, 10:35 AM
Tony11 Tony11 is offline
Registered User
2004 Maxima
 
Join Date: Jan 2018
Posts: 1
Default

Your post worked for me too... thank you so much!
Reply With Quote
  #11  
Old 01-08-2021, 08:57 AM
HarryDamian HarryDamian is offline
Registered User
1999 GTR
2003 Frontier Crew Cab
 
Join Date: Apr 2019
Posts: 2
Default

Your post really helped me fixing the issue with windshield vipers, i was about to take my car to the windshield replacement experts but i easily handled the issue after seeing this post.
Reply With Quote
Reply

Tags
2005, altima, nissan, windshield, wipers, working

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 09:06 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.