Login  |  Register
Nissanhelp.com - All About Nissan
Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Nissan OBDII Codes Glossary & Acronyms More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
P0345 - Camshaft Position Sensor Forums > > P0345 - Camshaft Position Sensor P0345 - Camshaft Position Sensor
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 08-06-2009, 08:18 AM
itsjustmewarren
Guest
 
Posts: n/a
Default P0345 - Camshaft Position Sensor

Hey,

So my car (2003 Altima 3.5L SE) has been having trouble turning over as of late and has stalled on me once, the SES light came on, I used the blink code to determine its a P0345 code which leads to a bad Camshaft Position Sensor.

Is there any way I can determine which side the problem is happening, I have called around and the best price I can get is around 100 bucks for each and would rather not replace both if I can get away with it.

Thanks!
Reply With Quote
  #2  
Old 08-08-2009, 10:42 AM
itsjustmewarren
Guest
 
Posts: n/a
Default

with a little more research I found this:

The front of the engine is pointed toward the right fender. The firewall side of the engine is the "right" bank or #1. The radiator side is the "left" bank or #2. Also, according to the service manual there is a cam pos. sensor on each bank.

so that would point to my problem being with the left bank

Nissan OBD-II Trouble Code P0345
Reply With Quote
  #3  
Old 08-09-2009, 11:44 AM
crankshaft crankshaft is offline
Enthusiast
2004 Altima
 
Join Date: Dec 2008
Location: Greenville, sc
Posts: 30
Default

I don't know how to tell which one is bad, but if both cam sensors are the same, buy one & replace the easiest one. If the problem goes away great; if not swap the sensor to the other bank.
Reply With Quote
  #4  
Old 08-09-2009, 03:12 PM
streamcast streamcast is offline
Master Enthusiast
1997 Altima
1995 Sentra
1995 Nissan sentra
 
Join Date: Jan 2009
Location: CANADA
Age: 49
Posts: 1,214
Default

These sensors are different I do believe. I would make a good guess and say the cam sensor at fault is the bank 1 sensor which is on back head on drivers side. I make this assumption because P0340 is usally for bank 1 cam sensor.
Reply With Quote
  #5  
Old 10-31-2009, 02:32 PM
Roccobro
Guest
 
Posts: n/a
Default

What was the outcome Warren?

Justin
Reply With Quote
  #6  
Old 11-01-2009, 08:15 AM
itsjustmewarren
Guest
 
Posts: n/a
Default

it was bank 1 cam shaft sensor, the repair was pretty simple to do, I kept looking on the front of the engine bay but its actually left of the fuse box in the engine bay, pretty easy to find if you know where your looking.
Reply With Quote
  #7  
Old 11-02-2009, 12:16 AM
Roccobro
Guest
 
Posts: n/a
Default

Perfect!

Buying the parts tomorrow.


Justin
Reply With Quote
  #8  
Old 11-05-2009, 04:35 PM
streamcast streamcast is offline
Master Enthusiast
1997 Altima
1995 Sentra
1995 Nissan sentra
 
Join Date: Jan 2009
Location: CANADA
Age: 49
Posts: 1,214
Default

Was the sensor replaced on the head closest to the rad or firewall?
Reply With Quote
  #9  
Old 11-05-2009, 05:06 PM
infiniti master
Guest
 
Posts: n/a
Default

the sensors where recalled on some vin ranges so u know
Reply With Quote
  #10  
Old 11-07-2009, 06:10 PM
Roccobro
Guest
 
Posts: n/a
Default

I could not find any of that information on the recall. Would have been nice as the sensors are $75 in my neck of the woods.

The sensor for that code is by the fuse box... bank closer to the radiator.

Fixed my problem, but replaced both sensors because the lady boss said to!

Justin
Reply With Quote
  #11  
Old 11-08-2009, 04:16 PM
streamcast streamcast is offline
Master Enthusiast
1997 Altima
1995 Sentra
1995 Nissan sentra
 
Join Date: Jan 2009
Location: CANADA
Age: 49
Posts: 1,214
Default

Just for future reference the head closest to the rad is Bank 2, just incase you need to get other parts such as O2 sensors etc.
Reply With Quote
  #12  
Old 11-08-2009, 05:09 PM
digitaldxing digitaldxing is offline
Registered User
2003 Altima
2005 Xterra
 
Join Date: Oct 2009
Posts: 4
Default

Recalls go by VIN#. I had major work done for my 03' Altima that now saves me gas!

Site that gives you a list of recalls:
Nissan Recalls -

Check out this post for sensor:

Nissanhelp.com - digitaldxing's Album: 2003 Nissan Altima Crankshaft Position Sensor - Picture
Reply With Quote
  #13  
Old 11-08-2009, 05:25 PM
Roccobro
Guest
 
Posts: n/a
Default

Your second link is for 2.5l alti's. Not our 3.5l.

Justin
Reply With Quote
  #14  
Old 02-14-2011, 04:40 PM
HotRodWillys
Guest
 
Posts: n/a
Default P0340; Cam Position Sensor, Bank1

My 3.5 liter Altima was experiencing stalling and hard starting but at no time did the Service Engine Light come on. However, upon connecting my diagnostic analyzer to the ODBII port I received a “PO340; Cam Position Sensor, Bank 1” failure code. Replacing the sensor fixed the problem and cleared the code.

To replace the sensor you need a few tips: First, there are 2 Cam position sensors on the V6. These are located by on the same side as the master cylinder and not on the front of the engine where the belts are. Bank 1 is the side closest to the firewall. The cam position sensors are found on the side of the cylinder heads. Note that both sensors are different and can be distinguished by the connector angle attachment. The Bank 1 sensor has a straight connector while Bank 2 has an angled connector attachment.

To replace the sensor, it is best to spray a lubricant like WD40 into the openings of the connector. The only way to release the connector from the sensor is to push down on the inner portion all the way down before the connector will release. Lubricating the sliding portion of the connector will make it easier to remove. You will break the connector if you remove it any other way! Be patient and she’ll cooperate!

Last edited by HotRodWillys; 02-14-2011 at 04:44 PM. Reason: None
Reply With Quote
  #15  
Old 10-03-2011, 08:37 PM
sparves
Guest
 
Posts: n/a
Default Thank you

After all the guessing games, I finally found the real answer. Thank you HotRodWillys for useful posting.
Reply With Quote
Reply

Bookmarks

Tags
camshaft, p0345, position, sensor

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 02:40 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.