Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2014 370Z Coupe 2014 370Z Coupe Nismo 2014 370Z Roadster 2013 Altima Coupe 2014 Altima Sedan 2014 Armada 2014 Cube 2014 Frontier Crew 2014 Frontier King 2014 GT-R 2014 JUKE 2014 JUKE NISMO 2013 Leaf 2014 Maxima
2014 Murano 2013 CrossCabriolet 2013 NV Cargo 2013 NV Passenger 2013 NV200 2014 Pathfinder 2014 Pathfinder Hybrid 2014 Quest 2014 Rogue 2014 Sentra 2014 Titan Crew 2014 Titan King 2014 Versa Note 2014 Versa Sedan 2014 Xterra Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts Ultimate Reflector Auto Sun Shades Custom Fit Car Covers Auto Snow Shades Berber Auto Mats Coco Auto Mats Designer Auto Mats Diamond Plate Auto Mats Fashion Auto Mats Flexomats Auto Mats Hexomats Auto Mats
Register FAQ Social Groups Mark Forums Read
Forums Nissan Models Titan heater will not get hot
Forgot Password? Join Us!


Titan Nissan Titan Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10-08-2007, 06:30 AM
brettaaron's Avatar
Registered User

2006 titan
 
Join Date: Sep 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default heater will not get hot

heater does not get hot. hoses going to heater core are very hot, but air out the vents with the heater on is barely warm. fan function is normal, and i am out of warranty by about a 1000 miles now . checked for cooling system leaks, no leaks. radiator and reservoir are at full. thanks
Reply With Quote
  #2 (permalink)  
Old 10-08-2007, 07:24 AM
vpnavy's Avatar
Tech Enthusiast
2006 Maxima
 
Join Date: Mar 2007
Location: Centralia, PA
Posts: 2,135
Thanks: 0
Thanked 12 Times in 12 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Originally Posted by brettaaron View Post
heater does not get hot. hoses going to heater core are very hot, but air out the vents with the heater on is barely warm. fan function is normal, and i am out of warranty by about a 1000 miles now . checked for cooling system leaks, no leaks. radiator and reservoir are at full. thanks
Until a Specialist replies...I browsed your Service Manual Section ATC - Automatic Air Conditioner (before you ask - it covers both Heat and Air) and found the following:

AIR MIX DOORS CONTROL - The air mix doors are automatically controlled so that in-vehicle temperature is maintained at a predetermined
value by the temperature setting, ambient temperature, in-vehicle temperature and amount of sunload.

When you select your mode (vents, etc.) - do you hear anything moving? Is the temperature the same whether it is coming from the vents or on the floor?
__________________
2006 Maxima 3.5 SL Sedan

SHOW YOUR SUPPORT!
Subscribe

FIND OUT WHAT YOUR REPAIR SHOULD COST?
Repair Cost Estimator

BUY NISSAN ACCESSORIES!
Nissanhelp Store
Reply With Quote
  #3 (permalink)  
Old 10-08-2007, 07:46 AM
brettaaron's Avatar
Registered User

2006 titan
 
Join Date: Sep 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

air temp is the same out of all vents, floor or dash. when switching temp dial from hot to cold you can hear the air mix motor and door moving. at full cold there is no heat. at full hot it is barely warm. a/c works great, very cold.
Reply With Quote
  #4 (permalink)  
Old 10-08-2007, 09:47 AM
vpnavy's Avatar
Tech Enthusiast
2006 Maxima
 
Join Date: Mar 2007
Location: Centralia, PA
Posts: 2,135
Thanks: 0
Thanked 12 Times in 12 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Originally Posted by brettaaron View Post
air temp is the same out of all vents, floor or dash. when switching temp dial from hot to cold you can hear the air mix motor and door moving. at full cold there is no heat. at full hot it is barely warm. a/c works great, very cold.
Again, until a Specialist replies...I found this Titan thread... My heater quit blowing hot air!
Reply With Quote
  #5 (permalink)  
Old 10-08-2007, 10:39 AM
kev82970's Avatar
Registered User

2004 Nissan Titan
 
Join Date: Jul 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I have the same problem with my 2004 Titan, it used to get hot in about 5 minutes until this fall. Now it takes 30 minutes or more and it cools off when fan is switched to high. Seems like the hoses are hot to heater. Any help would be appreciated!
Reply With Quote
  #6 (permalink)  
Old 01-29-2008, 12:46 PM
mister burns's Avatar
Registered User

2008 xe cc
 
Join Date: Jan 2008
Location: Poway, CA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

It sounds like a clogged up heater core to me. I had a Mercury Sable that needed a back-flush on the heater core every year or two. Hope this helped.
Reply With Quote
  #7 (permalink)  
Old 02-01-2008, 01:03 PM
kingofkool's Avatar
Registered User
2004 Titan Crew Cab
2004 titan
 
Join Date: Oct 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Check the engine temp and see if its too low. If it is the thermostat is stuck open.
Reply With Quote
  #8 (permalink)  
Old 03-06-2008, 09:52 AM
tdavey41's Avatar
Registered User

2004 Titan King Cab 4x4
 
Join Date: Mar 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Originally Posted by brettaaron View Post
heater does not get hot. hoses going to heater core are very hot, but air out the vents with the heater on is barely warm. fan function is normal, and i am out of warranty by about a 1000 miles now . checked for cooling system leaks, no leaks. radiator and reservoir are at full. thanks
Brett, I seem to be having that problem too. Were you able to find a fix? I have read some posts about replacing the fan control knob is the fix. Have heard anything about that?
Reply With Quote
  #9 (permalink)  
Old 03-16-2008, 09:02 PM
solow's Avatar
Registered User

2004 Maxima
 
Join Date: Mar 2008
Location: OKC
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Originally Posted by vpnavy View Post
Until a Specialist replies...I browsed your Service Manual Section ATC - Automatic Air Conditioner (before you ask - it covers both Heat and Air) and found the following:

AIR MIX DOORS CONTROL - The air mix doors are automatically controlled so that in-vehicle temperature is maintained at a predetermined
value by the temperature setting, ambient temperature, in-vehicle temperature and amount of sunload.

When you select your mode (vents, etc.) - do you hear anything moving? Is the temperature the same whether it is coming from the vents or on the floor?

hey i have the same problem... like u described above, if i hear anything move, yes i hear like a door move to another direction, and also when the AC/heater is on, i hear something blockin it... how do i go about that?
Reply With Quote
Reply

Bookmarks

Tags
heater, hot

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 07:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0