Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2017 Armada 2016 Altima Sedan 2016 Frontier 2016 JUKE 2016 LEAF 2016 Maxima 2016 Murano 2016 NV 2016 Rogue 2016 Sentra 2016 Titan XD 2016 Versa Note 2016 Versa Sedan 2016 Z Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > 06 Titan running lights issue
Forgot Password? Join Us!


Titan Nissan Titan Discussion Forum

User Tag List

Reply
 
Thread Tools Display Modes
  #1  
Old 07-06-2015, 07:30 PM
Jimmydad's Avatar
Jimmydad Jimmydad is offline
Registered User
2006 Titan King Cab
 
Join Date: Jul 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default 06 Titan running lights issue

I have a 06 Titan and my running lights fuse blows every time I turn on. Have searched the truck for a short and traced the circuit as well. Led me to the BCM in which I found doesn't have the 2fuses added to it just curious if somehow there is issue causing this short in that circuit? Everything else in truck works fine! Thanks for help
Reply With Quote
  #2  
Old 07-08-2015, 10:45 AM
Jimmydad's Avatar
Jimmydad Jimmydad is offline
Registered User
2006 Titan King Cab
 
Join Date: Jul 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Anyone had trouble with there running lights? I have checked everything to find a short that is causing fuse to blow! Headlight switch, BCM light harnesses! Please help
Reply With Quote
  #3  
Old 02-09-2017, 12:22 AM
MixerO's Avatar
MixerO MixerO is offline
Registered User
2005 Titan Crew Cab
 
Join Date: Oct 2016
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

My fuse went out too. I now disconnect my boat trailer lights before backing into the water. So far this has worked for me. Someone else mentioned that their wiring harness near the muffler had been burned when the muffler fell off and he drove it like that for a while. My muffler also fell off and had to have it re-welded. That part of the harness runs right along the exhaust on the frame. Check for burned or brittle wiring near the muffler.

Or it could just be a bad IPDM shorting out the fuse. The IPDM contain the faulty recalled ECM relays.
Reply With Quote
Reply

Bookmarks

Tags
issue, lights, running, titan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:00 PM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2017 Nissanhelp.com
AutoCodes.com - Engine-Codes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.