Login  |  Register
Nissanhelp.com - All About Nissan
2018 Altima 2018 Armada 2018 Frontier 2018 GTR 2018 LEAF 2018 Maxima 2018 Murano 2018 NV 2018 Pathfinder 2018 Rogue 2018 Sentra 2018 Titan XD 2018 Versa Note 2018 Versa Sedan 2018 Z
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > 06 Titan running lights issue
Forgot Password? Join Us!


Titan Nissan Titan Discussion Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 07-06-2015, 06:30 PM
Jimmydad Jimmydad is offline
Registered User
2006 Titan King Cab
 
Join Date: Jul 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default 06 Titan running lights issue

I have a 06 Titan and my running lights fuse blows every time I turn on. Have searched the truck for a short and traced the circuit as well. Led me to the BCM in which I found doesn't have the 2fuses added to it just curious if somehow there is issue causing this short in that circuit? Everything else in truck works fine! Thanks for help
Reply With Quote
  #2  
Old 07-08-2015, 09:45 AM
Jimmydad Jimmydad is offline
Registered User
2006 Titan King Cab
 
Join Date: Jul 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anyone had trouble with there running lights? I have checked everything to find a short that is causing fuse to blow! Headlight switch, BCM light harnesses! Please help
Reply With Quote
  #3  
Old 02-08-2017, 11:22 PM
MixerO MixerO is offline
Registered User
2005 Titan Crew Cab
 
Join Date: Oct 2016
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

My fuse went out too. I now disconnect my boat trailer lights before backing into the water. So far this has worked for me. Someone else mentioned that their wiring harness near the muffler had been burned when the muffler fell off and he drove it like that for a while. My muffler also fell off and had to have it re-welded. That part of the harness runs right along the exhaust on the frame. Check for burned or brittle wiring near the muffler.

Or it could just be a bad IPDM shorting out the fuse. The IPDM contain the faulty recalled ECM relays.
Reply With Quote
Reply

Bookmarks

Tags
issue, lights, running, titan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:57 PM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2018 Nissanhelp.com
AutoCodes.com - Engine-Codes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.