Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2014 370Z Coupe 2014 370Z Coupe Nismo 2014 370Z Roadster 2013 Altima Coupe 2014 Altima Sedan 2014 Armada 2014 Cube 2014 Frontier Crew 2014 Frontier King 2014 GT-R 2014 JUKE 2014 JUKE NISMO 2013 Leaf 2014 Maxima
2014 Murano 2013 CrossCabriolet 2013 NV Cargo 2013 NV Passenger 2013 NV200 2014 Pathfinder 2014 Pathfinder Hybrid 2014 Quest 2014 Rogue 2014 Sentra 2014 Titan Crew 2014 Titan King 2014 Versa Note 2014 Versa Sedan 2014 Xterra Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts Ultimate Reflector Auto Sun Shades Custom Fit Car Covers Auto Snow Shades Berber Auto Mats Coco Auto Mats Designer Auto Mats Diamond Plate Auto Mats Fashion Auto Mats Flexomats Auto Mats Hexomats Auto Mats
Register FAQ Social Groups Mark Forums Read
Forums Nissan Models Sentra 2002 Sentra XE 1.8 stalling/rough idle
Forgot Password? Join Us!


Sentra Nissan Sentra Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-02-2008, 09:47 AM
shimmer's Avatar
Registered User
2002 Sentra
 
Join Date: Nov 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default 2002 Sentra XE 1.8 stalling/rough idle

Hi,
I was reading some of the forum posts pertaining to the Sentra. My problem with my Sentra model is that it stalls and idles rough while stopping at a traffic light or stop sign. This problem first occured @36K miles usually with the A/C on in the summer but has progressively gotten worse with it now occuring during the winter with the heater on. The car is hitting 90K miles, took it to the dealer with no luck diagnosing the problem except ajusting the idle and telling me it was the gas grade and quality I was using. I changed the air filter and the stalling/idling problem stopped for about 4 months but has sinced returned. The check engine light has not come on recently but has come on in the past which the dealer could not get a code. When it stalls out I can restart the car right away. The car has also stalled out going around a corner.

I cleaned the MAF using the CRC MAF spray and the problem has seemed to gone away for now. Could anything else be contributing to this problem such as a stuck EGR valve?
Reply With Quote
  #2 (permalink)  
Old 11-02-2008, 11:02 AM
NissanTech's Avatar
Super Moderator
2004 Xterra
 
Join Date: Jun 2005
Location: California
Age: 42
Posts: 11,333
Thanks: 425
Thanked 452 Times in 411 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Could anything else be contributing to this problem such as a stuck EGR valve?
Yes, but is not very common. Probably the most common problem is the MAF and since the problem changed with the new air filter and cleaning the MAF, the probabilities that the problems is the MAF are higher.
__________________
CarZone Auto Repair - Nissan Service Center - Van Nuys CA

Nissan OBD-II Trouble Codes

Show your support to our forums and get unlimited access to the knowledge base files: Subscribe
Reply With Quote
  #3 (permalink)  
Old 11-02-2008, 12:29 PM
sergey85's Avatar
Master Enthusiast
2002 Maxima
 
Join Date: Jan 2008
Location: Louisville,KY
Age: 28
Posts: 2,033
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

have autozone or advance auto scan your codes and see what codes u get and post it here
__________________

2002 Maxima GLE Silver on Black
| Berk Intake w/AEM Dryflow | Clear Sidemarker Lights w/PIAA L.E.D|PIAA L.E.D Courtesy and Licence Plate Lights|PIAA White Fogs |Fibre Customs EyeLids | 5% Limo Tint | Brembo Blanks and Hawk HPS Pads |Ebay FSTB|CATTMAN RSB| NWP VIAS Block plate and NWS Spacers| OEM Spoiler | 07 350 z rims on 235/45/18 Goodyear Eagle GT tires| Megan Racing OE-RS Catback |

in training

SHOW YOUR SUPPORT: Subscribe or Donate
Reply With Quote
  #4 (permalink)  
Old 11-10-2008, 04:54 AM
nanapino's Avatar
Registered User
2001 Sentra
 
Join Date: Oct 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

i seem to experioence the same problem with the sentra stall and engine goin off..i think the fuel grade is the problem bcos i changed my grade to a cleaner one and it has stopped malfunctioning.what is the MAF and how do i clean mine?
Reply With Quote
  #5 (permalink)  
Old 11-10-2008, 06:05 AM
vpnavy's Avatar
Tech Enthusiast
2006 Maxima
 
Join Date: Mar 2007
Location: Centralia, PA
Posts: 2,135
Thanks: 0
Thanked 12 Times in 12 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Originally Posted by nanapino View Post
SNIP...what is the MAF and how do i clean mine?
Briefly, A Mass airflow sensor is a device used by the engine control computer to measure the amount of air entering the engine through its air intake system.

I pulled this from your Service Manual Section EC - ENGINE CONTROL SYSTEM...

MASS AIR FLOW SENSOR

The mass air flow sensor is placed in the stream of intake air. It measures the intake flow rate by measuring a part of the entire intake flow. It consists of a hot film that is supplied with electric current from the ECM. The temperature of the hot film is controlled by the ECM a certain amount. The heat generated by the hot film is reduced as the intake air flows around it. The more air, the greater the heat loss.

Therefore, the ECM must supply more electric current to maintain the temperature of the hot film as air flow increases. The ECM detects the air flow by means of this current change.
__________________
2006 Maxima 3.5 SL Sedan

SHOW YOUR SUPPORT!
Subscribe

FIND OUT WHAT YOUR REPAIR SHOULD COST?
Repair Cost Estimator

BUY NISSAN ACCESSORIES!
Nissanhelp Store

Last edited by vpnavy; 11-10-2008 at 06:08 AM.
Reply With Quote
  #6 (permalink)  
Old 11-18-2008, 03:52 PM
luvdubs's Avatar
Registered User
2000 Sentra
 
Join Date: Nov 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I have the same car and problem.. it stall's at light's , parked and when idled in traffic also the check engine light is not on
Reply With Quote
  #7 (permalink)  
Old 11-20-2008, 06:02 AM
vitesse's Avatar
Registered User
2000 Sentra
 
Join Date: Nov 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default 2000 1.8 Sentra hesitation

Has anyone had a hesitation problem on exceleration at start up speed?
it has become quite obvious, other than that the response is fine.

Throttle posirion sensor?

Mass air flow?
Reply With Quote
  #8 (permalink)  
Old 11-20-2008, 08:11 AM
BigRedNole's Avatar
Registered User

2000 Sentra GXE
 
Join Date: Feb 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I had this same exact problem on my 2000 GXE. It almost feels as if the tranny is going at times. Other times it stalled at lights, idle, and when ever it felt. The MAF had to be replaced and the car was back to new.

The OEM MAF does not work well or at all for the Sentra. It will not last long and you are stuck having to get Nissan original parts. It ain't too cheap. It cost me $750 for the part and labor.
Reply With Quote
  #9 (permalink)  
Old 02-23-2011, 07:30 AM
hobuth's Avatar
Registered User
2002 Sentra
 
Join Date: Feb 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default Nissan 2002 xe stallin

my car started stalling when ever i slowed down or stopped.all i did cleaned the cable connection going in MAF. it is fixed now. thanks for giving me idea.
Reply With Quote
  #10 (permalink)  
Old 05-16-2012, 03:24 PM
m_poplin's Avatar
Registered User
2001 Sentra
 
Join Date: May 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Hello I have a 01 sentra gxe 1.8.
when cold starting, rough idle and even kills motor, try to feed gas, acts like its flooding with gas. after engine warms(several starts and stalls later) when press gas, acts like not enough, dies down and almost stalls. however, if you just slightly feather down the gas pedal, it will run just so smoothly. should i also try this maf solution? or any other known issues? thanks - M_Poplin
__________________
2001 Sentra 1.8
Reply With Quote
  #11 (permalink)  
Old 06-26-2012, 05:24 PM
BOSN's Avatar
Registered User
2004 Sentra
 
Join Date: Jun 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default Rough Idol and Missing at cruising Speed

My 2004 Sentra 1.8 idles rough and stalls. It also is missfiring at various speeds (45, 60 etc). Nissan had the vehicle for 4 days and cannot diagnose the problem. Nothing showing up on the computer. I need a mechanic with a tool box instead of a laptop!
Reply With Quote
  #12 (permalink)  
Old 06-27-2012, 11:27 AM
bennyb53's Avatar
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 1,597
Thanks: 38
Thanked 181 Times in 175 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Default

Fortunately laptops are now the mechanic's new tool box. Even the good 'ol "Mr. Goodwrench" will not survive in today's drive-by-wire vehicles if he didn't keep up with the latest in car electronics.

I start by asking you to tell us (1) what sort of regular maintenance that you do, (2) and do you do all of them yourself, or some of them, or none at all, (3) what new parts, i,e. (oil change, coolant change, spark plugs, ignition coil, t-stat, O2 sensors, et., etc.) have been installed in the last 12 months and how many miles your car has. Thank you.
Reply With Quote
  #13 (permalink)  
Old 06-27-2012, 06:22 PM
BOSN's Avatar
Registered User
2004 Sentra
 
Join Date: Jun 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I change the oil and filters. That's about it. Bought the car about 8 months ago. It has 106k on it. When it first started a mechanic(not Nissan) changed the plugs and cleaned the throttle body. My son only drives it to school and work.

A few possibilities I've heard are:
Crankshaft Position sensor
Camshaft Position Sensor
Variable Timing Control Sensor
Throttle Body Failure

I think Nissan would've discovered these issues right? Thanks for the assist.
Reply With Quote
  #14 (permalink)  
Old 06-27-2012, 11:51 PM
bennyb53's Avatar
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 1,597
Thanks: 38
Thanked 181 Times in 175 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Default

Yes, if "ses" was lit they would come up with dtc. It is possible tho the failure is still developing. The car still run, right. Also verify the type of spark plugs the mechanic installed. It should be NGK, double or single platinum is up to you. Before replacing the cpk and cps sensors, do the power balance test.

Bring up engine to normal operating temp. Take it for a drive about 10 min. With engine at idle, remove the engine cover, Then disconnect the power supply connector to the ignition coil one at a time. After disconnecting, take note of what you observe. If engine stumble and even stall, that's normal, reconnect the power supply asap. If engine speed (rpm) do not change that coil is suspect and take note. Repeat until you've done all four. A failing ignition coil will exhibit no problem during cold start. After it heats up that's when the symptoms shows. You said you have a misfire at 45-60 mph. Also check and replace if need be your air cleaner. Let us know of the results.
Reply With Quote
  #15 (permalink)  
Old 05-02-2013, 06:08 PM
tekerrigan's Avatar
Registered User
2002 Sentra
2002 Sentra GXE
 
Join Date: May 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Smile Hope I've found the solution

My 2002 Sentra GXE has this exact problem. FINALLY it stalled enough times that the Service Engine Soon light came on. I immediately took it for a diagnostic test and was relieved to find out it was a Mass Air Flow code. Thankfully, I had purchased an after market sensor online for $35 that very same day. This solution was a shot in the dark after reading several forums, but it was a better solution than replacing the throttle body at $600 as suggested by my local Nissan dealership.

With 77k miles, my Sentra is certainly worth spending a few hundred dollars to fix but who doesn't want to save as much money as possible? Anyway, I had the MAF sensor replaced today for an additional $35 in labor, and I can't wait to find out if the problem is currently resolved.

Like the OP, it didn't matter if I was driving or stopped at a light. I also had put premium gas for the last two weeks prior to replacement and the problem only seemed to get worse (probably due to waiting so long). In addition to replacing the sensor today, I also installed a new air filter.

My A/C and heat control is broken at the moment so I'm not sure if using the temperature controls added to the problem.

Time warp back to 6 months ago when I took it to the dealer, this is what happened:

- mechanics couldn't replicate the problem after several test drives
- they adjusted my idle
- they cleaned my fuel injectors
- they cleaned the throttle body

No code was being thrown and I was told to pick it up. As soon as they pulled the car up for me to take, it stalled. Still, no code. At least someone besides me got to witness the problem.

As this seems to be a rampant problem, I will update if any problems arise after this latest "fix". Fingers crossed.

Last edited by tekerrigan; 05-02-2013 at 06:16 PM.
Reply With Quote
Reply

Bookmarks

Tags
2002, 2002 sentra xe 1.8, idle, idling problem, sentra, stalling, stalling or rough

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 06:41 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0