Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2017 Armada 2016 Altima Sedan 2016 Frontier 2016 JUKE 2016 LEAF 2016 Maxima 2016 Murano 2016 NV 2016 Rogue 2016 Sentra 2016 Titan XD 2016 Versa Note 2016 Versa Sedan 2016 Z Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > Smoke under the hood and service engine light on.
Forgot Password? Join Us!


Sentra Nissan Sentra Discussion Forum

User Tag List

Reply
 
Thread Tools Display Modes
  #1  
Old 01-05-2012, 10:18 AM
Georgiaboy4ever's Avatar
Georgiaboy4ever
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Unhappy Smoke under the hood and service engine light on.

So my service engine light kept coming on and off. Until it stayed on. I went to Autozone and had them look up the codes for it. And they said that the thermostat wires or the thermostat itself was the issue. Not soon after that my car started having white smoke come from the under the hood. I replaced the thermostat and turned the car back on and let it idle to see if everything was working right. It still smoked and the check engine light was still on. I found that the smoke was coming from under the heat shield in the front part of the engine. I dont know what to do. Any suggestions at this point?
Reply With Quote
  #2  
Old 01-05-2012, 12:10 PM
bennyb53's Avatar
bennyb53 bennyb53 is offline
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 1,925
Thanks: 45
Thanked 225 Times in 217 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Default

You need to erase the code. Disconnect the battery ground cable for at least 20 minutes. If SES light comes back you have other issues. Scan the ecm again.

Are you losing coolant or having overheating issue. From your description, it could be cracks on any of the hoses and not the most serious cracks. Check the hoses first and give us an update. Hope this helps.
Reply With Quote
Reply

Bookmarks

Tags
engine, hood, light, service, smoke

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:12 PM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2016 Nissanhelp.com
AutoCodes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.