Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2014 370Z Coupe 2014 370Z Coupe Nismo 2014 370Z Roadster 2013 Altima Coupe 2014 Altima Sedan 2014 Armada 2014 Cube 2014 Frontier Crew 2014 Frontier King 2014 GT-R 2014 JUKE 2014 JUKE NISMO 2013 Leaf 2014 Maxima
2014 Murano 2013 CrossCabriolet 2013 NV Cargo 2013 NV Passenger 2013 NV200 2014 Pathfinder 2014 Pathfinder Hybrid 2014 Quest 2014 Rogue 2014 Sentra 2014 Titan Crew 2014 Titan King 2014 Versa Note 2014 Versa Sedan 2014 Xterra Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts Ultimate Reflector Auto Sun Shades Custom Fit Car Covers Auto Snow Shades Berber Auto Mats Coco Auto Mats Designer Auto Mats Diamond Plate Auto Mats Fashion Auto Mats Flexomats Auto Mats Hexomats Auto Mats
Register FAQ Social Groups Mark Forums Read
Forums Nissan Models Rogue Vent Control Valve Code P0455
Forgot Password? Join Us!


Rogue Nissan Rogue Discussion Forum

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08-22-2008, 05:59 AM
rstew88410's Avatar
Registered User

2008 Rogue
 
Join Date: Dec 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default Vent Control Valve Code P0455

My Rogue has 12,000 miles on it and the Service Engine Light came on. I checked and found code P0455. I tightened the gas cap, cleared the code but it came on again after 40 miles of driving. I took it to the dealer today and Nissan found a defective Vent Control Valve. Has this happened to anyone else?
Reply With Quote
  #2 (permalink)  
Old 08-22-2008, 12:50 PM
sergey85's Avatar
Master Enthusiast
2002 Maxima
 
Join Date: Jan 2008
Location: Louisville,KY
Age: 28
Posts: 2,033
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

u are right about it(tightening the gas cap) but sometimes it could be that the gas cap damaged or the seal is bad.u can try to buy one and see if that fixes or assuming u still have your warranty take it to the dealer
__________________

2002 Maxima GLE Silver on Black
| Berk Intake w/AEM Dryflow | Clear Sidemarker Lights w/PIAA L.E.D|PIAA L.E.D Courtesy and Licence Plate Lights|PIAA White Fogs |Fibre Customs EyeLids | 5% Limo Tint | Brembo Blanks and Hawk HPS Pads |Ebay FSTB|CATTMAN RSB| NWP VIAS Block plate and NWS Spacers| OEM Spoiler | 07 350 z rims on 235/45/18 Goodyear Eagle GT tires| Megan Racing OE-RS Catback |

in training

SHOW YOUR SUPPORT: Subscribe or Donate

Last edited by sergey85; 08-22-2008 at 12:52 PM.
Reply With Quote
  #3 (permalink)  
Old 08-22-2008, 07:30 PM
NissanTech's Avatar
Super Moderator
2004 Xterra
 
Join Date: Jun 2005
Location: California
Age: 43
Posts: 11,376
Thanks: 428
Thanked 463 Times in 418 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Has this happened to anyone else?
I haven't seen it on the Rogue, but it was very common on other models.
__________________
CarZone Auto Repair - Nissan Service Center - Van Nuys CA

Nissan OBD-II Trouble Codes

Show your support to our forums and get unlimited access to the knowledge base files: Subscribe
Reply With Quote
  #4 (permalink)  
Old 09-08-2008, 06:54 AM
rstew88410's Avatar
Registered User

2008 Rogue
 
Join Date: Dec 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

The dealer got my vent control valve in and is replacing it today. They said there have been 4 other reports of problems with the vent control valve on the Rogues.
Reply With Quote
  #5 (permalink)  
Old 09-08-2008, 07:32 AM
NissanTech's Avatar
Super Moderator
2004 Xterra
 
Join Date: Jun 2005
Location: California
Age: 43
Posts: 11,376
Thanks: 428
Thanked 463 Times in 418 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Originally Posted by rstew88410 View Post
The dealer got my vent control valve in and is replacing it today. They said there have been 4 other reports of problems with the vent control valve on the Rogues.
Thank you for letting us know, I hope that takes of the problem.
Reply With Quote
  #6 (permalink)  
Old 10-17-2008, 06:21 AM
kingkong69's Avatar
Registered User
2002 Maxima
1998 Altima
 
Join Date: Oct 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Angry 2002 Maxima SE: Vent Control Valve changed 4 times!

Owned a 2002 Maxima SE from new. SERVICE ENGINE SOON indicator came on 5 times, 4 of which the dealer said was due to vent control valve being defective. After the 3rd replacement, I kept the defective part and asked the local Unionville ONT dealer to get Nissan Canada involved. They said they could not do anything since the car was out of warranty. Previous vent control valve lasted 16 months. Part is warranted for 12 months. Decided to call Nissan Canada in person. After a few calls, the CSR told me the car is out of warranty and they could do nothing. Dealer said they would cooperate and send maintenance history to Nissan Canada, but they don't care. Changing the same part 4 times in 6 years at $350 a pop....that's outrageous...or am I expecting too much. I guarantee you that when my 2 Nissans need replacing, it won't be with a Nissan or Infinity product. Lobbying both sides of my extended family and friends to boycott this company is top on my list. If they google for "nissan vent control valve", they would start to see a trend.
Reply With Quote
  #7 (permalink)  
Old 11-21-2008, 11:03 AM
xterramexico05's Avatar
Tech Enthusiast
2005 Xterra
 
Join Date: Oct 2008
Posts: 328
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default vent control valve

if its the valve also known as the purge valve on the carbon canister, ask the dealer for the so-called broken valve and take it home...... sometimes the spring that is visible in the valve gets stuck or twisted and also might have dirt or dust ...... you can clean them and with a toothpick make the spring go back to original position..... i saved my first purge valve and it was dirty and spring was stuck in an angle..... then 6 months later my replacement valve was stuck again and i replaced with my original valve after cleaning and placing spring back into place.... p.s after cleaning valve, you need to use 2 wires to check current..... positive wire to positive side and negative to negative... you will hear the valve close if it was only stuck due to dirt or spring being stuck.... if you dont hear the valve close then it no longer works....
Reply With Quote
  #8 (permalink)  
Old 05-17-2009, 06:02 AM
RakeshG's Avatar
Registered User
2008 Rogue
 
Join Date: May 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default Vent Control Valve

Quote:
Originally Posted by rstew88410 View Post
My Rogue has 12,000 miles on it and the Service Engine Light came on. I checked and found code P0455. I tightened the gas cap, cleared the code but it came on again after 40 miles of driving. I took it to the dealer today and Nissan found a defective Vent Control Valve. Has this happened to anyone else?
Just joined this forum because exactly the same happened with my Rogue, albeit at 21000 plus miles. I was also put thru the Gas cap routine but eventually they replaced the valve yesterday. Does anyone know what this valve does?
Reply With Quote
  #9 (permalink)  
Old 06-28-2009, 09:02 AM
5523's Avatar
Registered User
2008 Sentra
1997 Altima
 
Join Date: Jun 2009
Location: Ct
Age: 31
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

This is a very common issue with the new(er) style vent control valve. I replace at least 4 or 5 a week. Nissan is working on a countermeasure vent control valve to resolve the issues. They have released the countermeasure v/c valve upon special request from Nissan Techline for gtr only at this point. Our gtr tech just replaced one on a 2009 gtr.
Reply With Quote
  #10 (permalink)  
Old 05-01-2011, 02:44 PM
Tillind's Avatar
Registered User
2008 Rogue
 
Join Date: May 2011
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Thumbs up PO455, 2008 Rogue --- THANKS!!!





My new Best Friends:



About a year and a half ago, our 2008 Nissan SERVICE ENGINE SOON light came on; at the time, I was in Balad Iraq working for a Defense Contractor. I had my wife take it to the local Nissan dealership---where I bought it and my 2007 Chevy Tahoe (just want to point out that I spent a lot of money there). They in turn plugged it in to the analyzer and it threw "a code" (I assume the P0455? They gave her the text book solution by telling her that it was most likely the gas cap, reset the light, changed her ~$70 and sent her on her marry way.

Before long, the light re-lit (because the monitor kicked back in) so she went back. This time they told her they would have to do a "smoke test" because they would have to do an in-depth diagnosis to figure out what was wrong. They said that this time it would be a minimum of $400.00. She asked if they guaranteed that doing this test would reveal what was wrong? They answered, NO! As I researched I found that if the light was not flashing, it was not that big a deal, so we waited to do anything about it.

Well, we moved to NC in January of 2010 and the light was still on. We registered the cars but there was no requirement to have an inspection until it is time to re-register the vehicles the following year. Now the year has come to an end. I bought my own code reader and there it was, the ole P0455. I decided to use the reader to reset the light and try to get the inspection done but the computers are obviously smarter than me. When they plugged it up, it showed that the system monitor was not working and they asked if I had dead battery lately because that would cause it not to read. They told me to drive it for about 30 miles or so and the system would start monitoring again. I did and well, guess what? Yup the light came back on. I sent a text to the wife and told her that we had to take it to the shop and get it fixed...

When I got home, she had been doing her research (because she is so resourceful) and came across this and a couple other sites which suggested that it may be the Vent Control Valve. I read on some possible fixes like taking it off and blowing it out or possibly putting a little WD-40 in it to possibly make it function again. After a little more looking around, I found that it was an easy job so I took it on as a DYI venture. I tried doing what all was suggested but the light came back on.

I looked around locally and found a valve that the auto parts store could have here the next day for around $85.00. Luckily they were worthless and incompetent and the valve didn't come in. I say that because I found it on Amazon for $53 (including next day shipping if you are a Prime Member). It is the old style but truthfully, I read that they last for several years or 30-40K miles so I couldn't see paying the up-charge for the new and improved version. I put that puppy on and reset the light and took her for a ride to see what happened. After about 40 miles, no light came on so I was optimistic. I pulled off and ran the monitor on her and low and behold, "0" codes. I drove it all day the next day and ran the test again and once again, "0".


I said all that to say this…This forum ROCKS and you folks saved me a LOT of money! Thanks for the help and I will definitely be using this site as long as I own a Nissan. The wife and I were talking and we just bet that the dealerships hate the internet and sites like these because they take a lot of profits out of their pockets!!



THANKS AGAIN!!! DCT
Reply With Quote
The Following User Says Thank You to Tillind For This Useful Post:
cuellar (09-01-2013)
  #11 (permalink)  
Old 05-01-2011, 03:22 PM
streamcast's Avatar
Master Enthusiast
1997 Altima
1995 Sentra
1995 Nissan sentra
 
Join Date: Jan 2009
Location: CANADA
Age: 44
Posts: 1,225
Thanks: 6
Thanked 46 Times in 44 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Just FYI i have seen this code on many Rogues over the past year starting to become as common as any other vehicle. Most of the time it is the vent control valve, some gas cap aand some seal on the evap pressure sensor located just above the vent control valve. I hope this helps. Most of the issues with the vent control valve is the location of the water separator at the rear bumper area. In winter snow and water and debris get caught up and runs back to the valve causing corroson and seizure. That is my take.
Reply With Quote
The Following User Says Thank You to streamcast For This Useful Post:
cuellar (09-01-2013)
  #12 (permalink)  
Old 05-01-2011, 03:29 PM
Tillind's Avatar
Registered User
2008 Rogue
 
Join Date: May 2011
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Yeah, it seemed to be in a dumb location when I got in to it. Directly behind the rear wheel in an open box doesn't seem like the optimum place for it to be. Thanks.
Reply With Quote
  #13 (permalink)  
Old 05-01-2011, 04:42 PM
pejeeper's Avatar
Enthusiast
2008 Rogue
2008 Rogue
 
Join Date: Mar 2011
Location: Dutchess Cty, NY
Posts: 42
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

already been done on my 08 Rogue....last fall IIRC.
Reply With Quote
  #14 (permalink)  
Old 08-16-2011, 05:10 AM
dasbury412's Avatar
Registered User
2009 Rogue
 
Join Date: Aug 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default vent valve

I have a 2009 Rogue. Was told that the vent valve was the problem with the light coming on. I was told this by the dealership. I could not afford to have it fixed that day. So they cleared the light. It did not come back on till I filled the tank 5 days later. Is this common problem?
Reply With Quote
  #15 (permalink)  
Old 08-16-2011, 04:59 PM
pejeeper's Avatar
Enthusiast
2008 Rogue
2008 Rogue
 
Join Date: Mar 2011
Location: Dutchess Cty, NY
Posts: 42
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

replaced under warranty on my 2008
Reply With Quote
Reply

Bookmarks

Tags
code, control, p0455, valve, vent

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 03:24 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.