Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2017 Armada 2016 Altima Sedan 2016 Frontier 2016 JUKE 2016 LEAF 2016 Maxima 2016 Murano 2016 NV 2016 Rogue 2016 Sentra 2016 Titan XD 2016 Versa Note 2016 Versa Sedan 2016 Z Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > Rogue 2009 A/C Problem
Forgot Password? Join Us!


Rogue Nissan Rogue Discussion Forum

User Tag List

Reply
 
Thread Tools Display Modes
  #1  
Old 05-15-2017, 12:52 PM
SL_Nissan's Avatar
SL_Nissan SL_Nissan is offline
Registered User
2014 Pathfinder
2009 Rogue
 
Join Date: May 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Exclamation Rogue 2009 A/C Problem

Last year my 2009 rogue A/C decide to stop blowing cold air. Turns on no problem but no cold air. Brought it to my mechanic and diagnostic was a bad compressor. Decided not to fix as this is my second car. After a different repair we realized the diagnostic was bad and made me question his compressor failure call.
Spent some time playing around and here's where I'm at:

- Nissan Auto-Self-Test does not trigger the compressor clutch;
- No power goes to the compressor / clutch;
- Tried to by-pass the pressure switch, nothing works;
- Tried to by pass the clutch relay and apparently it can't be bypassed because it's built-in the IPDM

Based on that, is there any test I can do before replacing the IPDM to confirm it'S the problem?
Reply With Quote
  #2  
Old 05-15-2017, 04:23 PM
mpe235's Avatar
mpe235 mpe235 is offline
Moderator
2015 Rogue
 
Join Date: Jun 2006
Location: New York
Posts: 5,444
Thanks: 5
Thanked 242 Times in 225 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Default

Bad compressor clutches are very common on the rogue. Did you verify with a meter that the compressor doesn't get power? If it isn't make sure you check fuses first.
Reply With Quote
  #3  
Old 05-15-2017, 04:30 PM
SL_Nissan's Avatar
SL_Nissan SL_Nissan is offline
Registered User
2014 Pathfinder
2009 Rogue
 
Join Date: May 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Yes no power going ot it. I thought it could be because of the pressure switch but the auto self test does not trigger the clutch either. I couldn't find a fuse for it only information stating that the clutch relay was built in to the IPdM and not replacable
Reply With Quote
Reply

Bookmarks

Tags
2009, a or c, a/c, problem, rogue

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 09:39 AM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2017 Nissanhelp.com
AutoCodes.com - Engine-Codes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.