Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2017 Armada 2016 Altima Sedan 2016 Frontier 2016 JUKE 2016 LEAF 2016 Maxima 2016 Murano 2016 NV 2016 Rogue 2016 Sentra 2016 Titan XD 2016 Versa Note 2016 Versa Sedan 2016 Z Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > 2007 Murano Brake light on, ABS light on, speedometer out
Forgot Password? Join Us!


Murano Nissan Murano Discussion Forum

User Tag List

Reply
 
Thread Tools Display Modes
  #1  
Old 07-09-2017, 03:29 PM
greghermans's Avatar
greghermans greghermans is offline
Registered User
2007 Murano
 
Join Date: Jul 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default 2007 Murano Brake light on, ABS light on, speedometer out

After driving for 5 or 10 minutes, the ABS light goes on, brake light goes on, and the speedometer drops out, all simultaneously. Cruise control is interrupted and the green light flashes. Turning off the car and letting it cool down resets all to normal. Strangely, today I was able to drive it for one hour straight and there were no problems. Next drive later, it all happened again.

Checked the wheel sensors and they all have normal readings. There are no engine codes showing. Replaced the transmission speed sensor-but no effect.

Guess it is either the ABS module, or a wire issue somewhere. Has anyone experienced this? Any other troubleshooting techniques?
Reply With Quote
  #2  
Old 07-16-2017, 01:12 PM
smj999smj's Avatar
smj999smj smj999smj is offline
Master Enthusiast
2006 Pathfinder
2003 Frontier King Cab
2003 Frontier SVE
 
Join Date: Jun 2012
Location: Prospect, VA
Posts: 1,330
Thanks: 1
Thanked 217 Times in 201 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

There may not be any engine codes, but what about stored ABS system codes? I would want to know that information before doing anything. I would also look at the battery cable connections, making sure they are clean and tight, and that the charging system is charging properly.
Reply With Quote
  #3  
Old 08-12-2017, 01:49 PM
greghermans's Avatar
greghermans greghermans is offline
Registered User
2007 Murano
 
Join Date: Jul 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default ABS issue 2007 Murano AWD

Not sure how to access the stored engine codes, but seems like I would have to hire the dealership to do that. Definitely ruled out the charging system, as it was just replaced-same ABS problem exists. Did figure out that it is definitely related to ambient air temperature. No problems on a cool day. However, after driving for 15 to 45 minutes on a day above 80 degrees F, the problems start. Next morning, all resets and no lights. Thanks for taking your time.
Reply With Quote
Reply

Bookmarks

Tags
2007, abs, brake, light, murano, speedometer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:04 AM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2016 Nissanhelp.com
AutoCodes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.