Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2017 Armada 2016 Altima Sedan 2016 Frontier 2016 JUKE 2016 LEAF 2016 Maxima 2016 Murano 2016 NV 2016 Rogue 2016 Sentra 2016 Titan XD 2016 Versa Note 2016 Versa Sedan 2016 Z Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > 96 Maxima Code P0100
Forgot Password? Join Us!

Maxima Nissan Maxima Discussion Forum

User Tag List

Thread Tools Display Modes
Old 01-03-2009, 01:25 PM
Jackblk226's Avatar
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Default 96 Maxima Code P0100

After checking everything, setting the idle checking sensors,
It was running great! I hit a speed bump and check engine light comes on and then I stall.
Could it be that I have a short?


Reply With Quote
Old 01-03-2009, 01:33 PM
NissanTech's Avatar
NissanTech NissanTech is offline
Super Moderator
2004 Xterra
Join Date: Jun 2005
Location: California
Age: 45
Posts: 12,179
Thanks: 459
Thanked 553 Times in 496 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)

The P0100 code is for the Air Flow Meter which is a very common problem on your Maxima.

Nissan OBD-II Trouble Code P0100

I suggest inspecting the meter, the meter connector and the air filter.
CarZone Auto Repair - Nissan Service Center - Van Nuys CA

Nissan OBD-II Trouble Codes

Show your support to our forums and get unlimited access to the knowledge base files: Subscribe
Reply With Quote
Old 12-20-2009, 05:03 PM
FBMax's Avatar
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)

When you say Air Flow Meter do you mean the Mass Air Flow sensor?

I have the same code but the engine will not run above idle -- normal throttle application in neutral causes the engine to choke and die. Only if I very slowly give it throttle will the RPM rise to 2,500, but then it has a repeated stumble. (Run, cough, run, cough, etc.) Removing the MAF sensor connector makes no difference.

Air and fuel filters are good. I have properly cleaned the MAF sensor and inspected the internal electrics which appear fine.

Are the symptoms normal for the failure of this component or could this be an EGR tube clogging situation? I'll admit to running cheap-ass regular in this car for the past 3.5 years ... could that do it?

Thanks for any input.
Reply With Quote


code, maxima, p0100

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -8. The time now is 07:52 AM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2016 Nissanhelp.com
AutoCodes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.