Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2015 Armada 2015 Frontier 2015 GT-R 2015 JUKE 2015 Maxima 2015 Sentra 2015 Rogue 2015 Titan 2015 Xterra 2015 370Z
2014 370Z Coupe Nismo 2014 370Z Roadster 2014 Altima Sedan 2014 Cube 2014 JUKE NISMO 2014 Murano 2014 Pathfinder 2014 Pathfinder Hybrid 2014 Quest 2014 Versa Note 2014 Versa Sedan Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts Ultimate Reflector Auto Sun Shades Custom Fit Car Covers Auto Snow Shades Berber Auto Mats Designer Auto Mats Diamond Plate Auto Mats Fashion Auto Mats Hexomats Auto Mats
Register FAQ Social Groups Mark Forums Read
Forums > > Engine wont rev past 2500 rpm
Forgot Password? Join Us!


Frontier/HB/Truck Nissan Frontier/HB/Truck Discussion Forum

User Tag List

Reply
 
Thread Tools Display Modes
  #1  
Old 08-13-2012, 05:40 AM
kickstart's Avatar
kickstart kickstart is offline
Registered User
1997 Truck
 
Join Date: Dec 2011
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default Engine wont rev past 2500 rpm

97 pickup 2.4 and auto tranny.Not good at explaining but here it goes.When engine is cold and first start up of the day it runs fine till engine reaches operating temp.Once it warms up it will not rev past 2500 acts like a rev limiter kicks in.Checked codes only one it has is MAF sensor p100.Replaced and checked all wires and connections related .I have checked for vaccum leaks and have none.What really confuses me is while the engine is running i can completely cover throttle body with my hand and it will not choke the engine down .it appears to me air is entering the engine somewhere past the throttle body but where? and only when engine is warmed up.When engine is cold it will cause it to die.
Reply With Quote
  #2  
Old 08-13-2012, 10:30 PM
bennyb53's Avatar
bennyb53 bennyb53 is offline
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 1,761
Thanks: 44
Thanked 205 Times in 199 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Default

vehicle is in fail-safe mode. scan ECM for trouble code.
Reply With Quote
  #3  
Old 08-27-2012, 05:01 PM
kickstart's Avatar
kickstart kickstart is offline
Registered User
1997 Truck
 
Join Date: Dec 2011
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default More problems

First THANKS BennyB53 for your response.I had a bad MAF sensor.Now i am not getting any codes but engine is running very ruff and stalls after running for a minute or 2,will restart but have to feather gas to get it to running . acting as if it is starving for fuel.So i installed another fuel pump.Runs somewhat better at least no stalling but still runs ruff .The pump i added was an externally mounted one .the stock pump has been recently replaced and was running good before.I have also within the past 100 miles done a complete tuneup,air filter,plugs ,wires,cap,rotor,pcv,etc.TPS replaced recently also.Any more ideas anyone? Thanks in advance
Reply With Quote
  #4  
Old 08-28-2012, 01:11 AM
bennyb53's Avatar
bennyb53 bennyb53 is offline
Moderator
2002 Altima
2002 Altima
 
Join Date: Jan 2011
Location: Hawaii
Posts: 1,761
Thanks: 44
Thanked 205 Times in 199 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Default

1. you put in a new fuel pump but did you do fuel pressure test. if you didn't, you should. refer to engine control manual page EC-25. if NG replace fuel pressure regulator.
2. if fuel pressure is good, next thing I'll look at is the intake air control valve. it could be carbon up. remove, inspect and clean before replacing. refer to EC manual starting on page EC-221. have fun and let us know.
Reply With Quote
Reply

Bookmarks

Tags
2500, engine, past, rev, rpm

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 09:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.