Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2017 Armada 2016 Altima Sedan 2016 Frontier 2016 JUKE 2016 LEAF 2016 Maxima 2016 Murano 2016 NV 2016 Rogue 2016 Sentra 2016 Titan XD 2016 Versa Note 2016 Versa Sedan 2016 Z Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts
Register FAQ Social Groups Mark Forums Read
Forums > > Nissan Altima 2.5 2005 sensors problems Toronto, GTA
Forgot Password? Join Us!


Classifieds - Mechanic Wanted Need a mechanic in you area?

View Poll Results: Nissan Altima 2.5 problems engine light service soon
Crankshaft and camshaft problem 1 50.00%
need to replace both of them at the same time 1 50.00%
Voters: 2. You may not vote on this poll

User Tag List

Reply
 
Thread Tools Display Modes
  #1  
Old 08-16-2010, 02:51 PM
Nissan Operator's Avatar
Nissan Operator
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Default Nissan Altima 2.5 2005 sensors problems Toronto, GTA

If you are having problems with starting your car, the car stoles on you as you drive or come to a stop sing, the serive engine lights are on, then you have a problem with 2 sensors. You need to replace them both. If you take to a mechaniv shop or dealeriship it will cost you between $300-$500.

I and a bunch of my friends had same problem. I fixed my car and my friends car, and then friends of my friends started to call and I began to fix this problem for them at 50% cost less then of a shop/dealer.

If you live in Toronto or GTA, please call me now at 647-831-2102. The car must be called in order to work on it, so it is better that I come to your place. It is a dangerous problem and you should fix it right away.

Call now 647-831-2102

Taras
Reply With Quote
  #2  
Old 08-22-2010, 10:04 AM
Deafkid88's Avatar
Deafkid88
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Default

i have replaced both the camshaft and crankshaft on mine just recently, the check engine light came on at 70,000 miles exactly. and I'm at 71,500 now. I've replaced the two sensors and my lights are still on. I am tempting to change the speed sensor as well since I had a P0725 (Speed sensor) code come up on the reading. but do I need 1 speed sensor or two? My local AutoZone told me I just needed 1.. so that is where exactly in the engine part so I can replace?
Reply With Quote
Reply

Bookmarks

Tags
nissan altima eng light, nissan altima problems

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:49 PM.

Privacy Statement - Advertise with Us - Terms of Use - Copyright 1999-2017 Nissanhelp.com
AutoCodes.com - Engine-Codes.com - HelpForCars.net - Infinitihelp.com - Nissanhelp.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.