Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2015 Armada 2015 Frontier 2015 GT-R 2015 JUKE 2015 Maxima 2015 Sentra 2015 Rogue 2015 Titan 2015 Xterra 2015 370Z
2014 370Z Coupe Nismo 2014 370Z Roadster 2014 Altima Sedan 2014 Cube 2014 JUKE NISMO 2014 Murano 2014 Pathfinder 2014 Pathfinder Hybrid 2014 Quest 2014 Versa Note 2014 Versa Sedan Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts Ultimate Reflector Auto Sun Shades Custom Fit Car Covers Auto Snow Shades Berber Auto Mats Designer Auto Mats Diamond Plate Auto Mats Fashion Auto Mats Hexomats Auto Mats
Register FAQ Social Groups Mark Forums Read
Forums > > 2003 altima 2.5S engine service soon light ON CODE P0420
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

User Tag List

Reply
 
Thread Tools Display Modes
  #1  
Old 08-22-2007, 07:01 AM
chatha's Avatar
chatha chatha is offline
Enthusiast

2003 altima
 
Join Date: Aug 2007
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Question 2003 altima 2.5S engine service soon light ON CODE P0420

I have 2003 Altima 2.5S with 129k miles on it The engine light came ON last day. Read code P0420 CAT efficiency below threshold.... I reset the code and the light gone. I drove the car 10 days and then light came back again with the same code I reset it again then after couple of trips it came back again...
Any suggestion what causing it coming back again and again If CAT is bad or BAD O2 sensor then it should come back right away when the car will start. Why it take 8-10 days to come back again with the same code??? Any help will be appreciated
Reply With Quote
  #2  
Old 08-22-2007, 01:43 PM
mpe235's Avatar
mpe235 mpe235 is online now
Moderator
2013 Rogue
 
Join Date: Jun 2006
Location: New York
Posts: 5,250
Thanks: 4
Thanked 211 Times in 195 Posts
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Default

You need a new cat. convertor. The light will not come on until the computer test the system. This requires a specific drive pattern to complete. The only time the light will come on immediately on startup would be for a sensor that was disconnected or shorted out.
__________________
Nissan Master certified Technician
Hybrid and GTR certified
EV certified
ASE Master Certified.
Reply With Quote
  #3  
Old 08-23-2007, 10:17 AM
chatha's Avatar
chatha chatha is offline
Enthusiast

2003 altima
 
Join Date: Aug 2007
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

So if I put new CAT then I will be okay as the only code I retrieve was P0420?
Reply With Quote
  #4  
Old 08-23-2007, 10:18 AM
chatha's Avatar
chatha chatha is offline
Enthusiast

2003 altima
 
Join Date: Aug 2007
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

and does the 2002 2.5S altima has the same CAT as 2.5S 2003altima ? I have 2002 altima CAT I am wondering if I can put that on 03 altima 2.5S ?
Reply With Quote
  #5  
Old 08-23-2007, 12:04 PM
msatl's Avatar
msatl msatl is offline
Registered User

2000 Nissan Altima
 
Join Date: Nov 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

On my 2000 Altima GXE, for the same code, changing the Oxygen Sensor resolved the issue.
Reply With Quote
  #6  
Old 08-23-2007, 12:52 PM
chatha's Avatar
chatha chatha is offline
Enthusiast

2003 altima
 
Join Date: Aug 2007
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

which sensor ? fron tor rear ? how you know that sensor was BAD?
Reply With Quote
  #7  
Old 08-23-2007, 01:31 PM
msatl's Avatar
msatl msatl is offline
Registered User

2000 Nissan Altima
 
Join Date: Nov 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

The scanner pointed out Bank1 sensor which is on the front. I have a friend who runs an auto-parts shop; he recommended to get the O2 sensor replaced first, as it is the case generally. I got this done about three months ago, the check engine light has been off ever since!
Reply With Quote
Reply

Bookmarks

Tags
2003, 25s, altima, code, engine, light, p0420, service

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 07:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.