Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2014 370Z Coupe 2014 370Z Coupe Nismo 2014 370Z Roadster 2013 Altima Coupe 2014 Altima Sedan 2014 Armada 2014 Cube 2014 Frontier Crew 2014 Frontier King 2014 GT-R 2014 JUKE 2014 JUKE NISMO 2013 Leaf 2014 Maxima
2014 Murano 2013 CrossCabriolet 2013 NV Cargo 2013 NV Passenger 2013 NV200 2014 Pathfinder 2014 Pathfinder Hybrid 2014 Quest 2014 Rogue 2014 Sentra 2014 Titan Crew 2014 Titan King 2014 Versa Note 2014 Versa Sedan 2014 Xterra Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts Ultimate Reflector Auto Sun Shades Custom Fit Car Covers Auto Snow Shades Berber Auto Mats Coco Auto Mats Designer Auto Mats Diamond Plate Auto Mats Fashion Auto Mats Flexomats Auto Mats Hexomats Auto Mats
Register FAQ Social Groups Mark Forums Read
Forums Nissan Models Altima Service Engine Soon Light
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06-10-2007, 06:56 PM
KingCobra36's Avatar
Registered User

2003 Altima 2.5 SL
 
Join Date: Jan 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default Service Engine Soon Light

Hi, the Service Engine Soon light came on in my 2003 Altima 2.5SL. I checked the fuel cap as it said in the owner's manual and it appears to be fine.

I was wondering if it happens to be too much water in the gas tank due to bad gas and I use a water replacer additive would the light go out if the problem corrects itself or do I have to get it reset by a Nissan Technician even if the problem is corrected?

Thanks
Reply With Quote
  #2 (permalink)  
Old 06-11-2007, 10:15 AM
NissanTech's Avatar
Super Moderator
2004 Xterra
 
Join Date: Jun 2005
Location: California
Age: 42
Posts: 11,333
Thanks: 425
Thanked 452 Times in 411 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Default

You need to find out first what is the code. Go to your nearst auto parts store and have them check the codes for you, they usualy do it for free. With the code you can find out exactly what the problem is.
__________________
CarZone Auto Repair - Nissan Service Center - Van Nuys CA

Nissan OBD-II Trouble Codes

Show your support to our forums and get unlimited access to the knowledge base files: Subscribe
Reply With Quote
  #3 (permalink)  
Old 06-21-2007, 04:13 PM
KingCobra36's Avatar
Registered User

2003 Altima 2.5 SL
 
Join Date: Jan 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Hi, thanks for the info. I went to the dealer and the codes they pulled was P0335 crank sensor and P0725 eng speed signal.

The dealer changed the crank sensor and everything was working fine for a day but the engine service light came on again.

The car seems to be working fine since they changed the crank sensor and then about 5 days later the service engine went out. I called the dealer and they said it might be another code coming up now but if it is the crank sensor they will warranty the part. Hopefully it stays out since I had to pay for the crank sensor and they will probably charge me to dump the codes again :):censored:

I saw another thread with some people having the same issues. Is this common?
Reply With Quote
  #4 (permalink)  
Old 06-21-2007, 06:30 PM
NissanTech's Avatar
Super Moderator
2004 Xterra
 
Join Date: Jun 2005
Location: California
Age: 42
Posts: 11,333
Thanks: 425
Thanked 452 Times in 411 Posts
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Default

Yes, the crank sensor problem is common. There is recall for some 2003 altima, you should check if your altima fall in the VIN range. Here is the recall: VOLUNTARY RECALL CAMPAIGN 2003 NISSAN ALTIMA AND SENTRA WITH QR25DE ENGINE CRANK ANGLE SENSOR / ECM REPROGRAMMING
Reply With Quote
  #5 (permalink)  
Old 06-21-2007, 08:41 PM
KingCobra36's Avatar
Registered User

2003 Altima 2.5 SL
 
Join Date: Jan 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Hi, my vehicle does fall in that range. I had the ecm re-programmed back in Oct 2006. So it appears in that bulletin I'm not eligible for a refund since I had the crank sensor replaced after the ecm was re-programmed. Would I have any type of argument? I'm surprised my dealer didn't bring this up. It appears to me it's a fault on Nissan's end but proving it would be tough probably. Thanks for the info.
Reply With Quote
Reply

Bookmarks

Tags
engine, light, service

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 07:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0