Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2014 370Z Coupe 2014 370Z Coupe Nismo 2014 370Z Roadster 2013 Altima Coupe 2014 Altima Sedan 2014 Armada 2014 Cube 2014 Frontier Crew 2014 Frontier King 2014 GT-R 2014 JUKE 2014 JUKE NISMO 2013 Leaf 2014 Maxima
2014 Murano 2013 CrossCabriolet 2013 NV Cargo 2013 NV Passenger 2013 NV200 2014 Pathfinder 2014 Pathfinder Hybrid 2014 Quest 2014 Rogue 2014 Sentra 2014 Titan Crew 2014 Titan King 2014 Versa Note 2014 Versa Sedan 2014 Xterra Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts Ultimate Reflector Auto Sun Shades Custom Fit Car Covers Auto Snow Shades Berber Auto Mats Designer Auto Mats Diamond Plate Auto Mats Fashion Auto Mats Hexomats Auto Mats
Register FAQ Social Groups Mark Forums Read
Forums Nissan Models Altima 2003 altima 2.5 with a p0507 code
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-24-2007, 10:05 AM
countryboy9799's Avatar
Registered User

2003 altima
 
Join Date: Jan 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default 2003 altima 2.5 with a p0507 code

Hi all, new to the forum here and looking for advice on my gf's altima. About the middle of Dec. the service engine light came on so I called the dealer and he said it was probably the gas cap and to run it for a week and see if the light goes out. The light went out for about a week and then came on again, we ended up going to an autozone so I had it checked and came up with this code, the guy cleared the code and the light stayed off for about two weeks and came back on again.
Last night I checked it again and the same code came up, what should I be looking at? Should I try cleaning the throttle body and if so what is the procedure for this car? Thank's in advance
Scott
Reply With Quote
  #2 (permalink)  
Old 01-28-2007, 03:54 PM
countryboy9799's Avatar
Registered User

2003 altima
 
Join Date: Jan 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I ended up cleaning the throttle body with throttle body cleaner and put it back together only to have it now idle at about 1500 instead of the 900 before. Will it take some time for the computer to learn the idle speed because I unhooked the battery? In the service manual it had a procedure for idle air volume learning and I tried that but could not get it to work right, any suggestions would be apprieciated.
Reply With Quote
  #3 (permalink)  
Old 01-29-2007, 04:35 PM
dre351's Avatar
Tech Enthusiast
2004 Frontier Crew Cab
2012 GTR
2004 s/c 4x4 frontier
 
Join Date: Jul 2006
Location: pittsboro, north carolina
Age: 47
Posts: 309
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

if you sprayed cleaner in the throttle body it may be bad now. the problem is when you spray anything in it the fluid will run down the shaft and into the electronics destroying the throttle body. but the fact that it still rauns may be a good sign. it will probably need to have the idle volume learn reset with the nissan consult (scan tool).
__________________
Andre Dalrymple
Reply With Quote
  #4 (permalink)  
Old 01-30-2007, 07:28 AM
countryboy9799's Avatar
Registered User

2003 altima
 
Join Date: Jan 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

My nissan dealer told me to scrub the throttle body good with a toothbrush and use throttle body cleaner. Isnt that what they make TB cleaner so you can clean the TB?
Reply With Quote
  #5 (permalink)  
Old 06-01-2007, 07:43 PM
Birdman's Avatar
Registered User

2002 Altama
 
Join Date: Jun 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default 2002 Nissan Altama

I have the same problem Check engine light code P0507
Removed my TB and cleaned but before I did this also removed the electronics from it also! After installing it idle was @ 1100 RPM So reset the Idle Air Control (Note did not get the SES light to flash?) after doing this RPM's droped to 700. I also tryed the batery cable thing (holding them together for 10 seconds, off of the batery). The car will still hesatate when you start up,but if you acelerate it will clear up and run fine? About 200 miles SES light will come back on?

Thanks
Reply With Quote
  #6 (permalink)  
Old 11-28-2007, 03:17 PM
Cash's Avatar
Registered User

2003 Altima
 
Join Date: Nov 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

hello, i have the same year & model with P0507. I have read the comments above but where is this throttle body and what does it look like.

Any help will be appreciated.
Reply With Quote
  #7 (permalink)  
Old 12-03-2007, 09:38 AM
Cash's Avatar
Registered User

2003 Altima
 
Join Date: Nov 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Originally Posted by Birdman View Post
I have the same problem Check engine light code P0507
Removed my TB and cleaned but before I did this also removed the electronics from it also! After installing it idle was @ 1100 RPM So reset the Idle Air Control (Note did not get the SES light to flash?) after doing this RPM's droped to 700. I also tryed the batery cable thing (holding them together for 10 seconds, off of the batery). The car will still hesatate when you start up,but if you acelerate it will clear up and run fine? About 200 miles SES light will come back on?

Thanks
Hello Birdman, Are you saying this is not permanent fix and SES could appear again after 200 miles?
Reply With Quote
Reply

Bookmarks

Tags
2003, altima, code, p0507

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 08:32 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.