Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2015 Armada 2015 Frontier 2015 GT-R 2015 JUKE 2015 Maxima 2015 Sentra 2015 Rogue 2015 Titan 2015 Xterra 2015 370Z
2014 370Z Coupe Nismo 2014 370Z Roadster 2014 Altima Sedan 2014 Cube 2014 JUKE NISMO 2014 Murano 2014 Pathfinder 2014 Pathfinder Hybrid 2014 Quest 2014 Versa Note 2014 Versa Sedan Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts Ultimate Reflector Auto Sun Shades Custom Fit Car Covers Auto Snow Shades Berber Auto Mats Designer Auto Mats Diamond Plate Auto Mats Fashion Auto Mats Hexomats Auto Mats
Register FAQ Social Groups Mark Forums Read
Forums > > 2003 Nissan altima 2.5 S
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

User Tag List

Reply
 
Thread Tools Display Modes
  #1  
Old 08-29-2009, 05:43 AM
urtall1's Avatar
urtall1 urtall1 is offline
Registered User

2003 ALTIMA
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default 2003 Nissan altima 2.5 S

Hi, anybody out here who might know what my problem might be? I have the service engine light on, but have not got the code yet, but what is happening is, when I am at highway speed, say 60 miles an hour, the car is sluggish to speed up and if I was say trying to pass somebody and it downshifts and awful shaking noise is heard and it lacks power, or takes a while to speed up. I check the tranny fluid and its in the range and I've always had it drained and cleaned every 30K. my vehicle has 128K on it now. I replaced spark plugs at 100K. and it got a new throttle body earlier this year. any ideas? I hope to get the code this afternoon.

Dale
Reply With Quote
  #2  
Old 08-29-2009, 02:43 PM
tech22's Avatar
tech22 tech22 is offline
Master Enthusiast
2005 Frontier Crew Cab Frontier Crew Cab
05 nissan frontier
 
Join Date: Jan 2008
Location: alliance,ohio
Age: 61
Posts: 2,049
Thanks: 0
Thanked 12 Times in 11 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Need to pull code so we can help.
Reply With Quote
  #3  
Old 08-30-2009, 04:10 AM
urtall1's Avatar
urtall1 urtall1 is offline
Registered User

2003 ALTIMA
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default 2003 Nissan altima 2.5 S

Got the code, it is; PO420. read at AutoZone. According to them its the catalytic system, and possible problems were;

fuel system fault
large vacuum leak
ignitioin system fault
or faulty catalytic converter

and this website maybe narrowed it down further, I don't know, but your website said;

TW (two-way) Catalyst System, Bank 1. what ever that means. LOL

anyway, I did have my upper and lower radiator hoses replaced along with my thermostat recently and a coolant flush. it was performed by my mechanic, who routinely does not work on this car. I wonder if he knocked a hose loose or something. I plan to get under the car today to look for things that are not connected. and if you have any other suggestions, please let me know.

Dale
Reply With Quote
  #4  
Old 08-31-2009, 05:02 PM
streamcast's Avatar
streamcast streamcast is offline
Master Enthusiast
1997 Altima
1995 Sentra
1995 Nissan sentra
 
Join Date: Jan 2009
Location: CANADA
Age: 44
Posts: 1,225
Thanks: 6
Thanked 48 Times in 45 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I am not sure but it is possible that an ecm reprogramm maybe needed. But I will check.
Reply With Quote
  #5  
Old 09-01-2009, 11:47 AM
streamcast's Avatar
streamcast streamcast is offline
Master Enthusiast
1997 Altima
1995 Sentra
1995 Nissan sentra
 
Join Date: Jan 2009
Location: CANADA
Age: 44
Posts: 1,225
Thanks: 6
Thanked 48 Times in 45 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Call your local dealer with the serial info and inquire about any recalls that need to be done. There is a recall in canada for this. Not sure about the states.
Reply With Quote
  #6  
Old 09-02-2009, 01:45 AM
urtall1's Avatar
urtall1 urtall1 is offline
Registered User

2003 ALTIMA
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I took it in to a mechanic, (not the dealer) on monday and not my preferred mechanic and he said that the "thermal reactor" was plugged. and I remember earlier this summer one time I was backing up in an area off road and my tail pipe got a mouth full of dirt. I wonder if this caused the problem. I cleaned most of it out, but not all and I felt that the tailpipe pressure would blow out the rest if any that was still present. perhaps that was a bad assumption. I'm thinking to go to a different mechanic. The other one who said the thermal reactor was plugged said that part would have to be replaced at a cost of 600 bucks and then the system rechecked. I did not find any hose unconnected. and I tried perhaps unsuccessfully to put a vacuum on the tailpipes to possibly vacuum up any loose debris in the tailpipe tonite. car still runs and drives, just doesn't have the power it once had.
Reply With Quote
  #7  
Old 09-02-2009, 02:01 AM
streamcast's Avatar
streamcast streamcast is offline
Master Enthusiast
1997 Altima
1995 Sentra
1995 Nissan sentra
 
Join Date: Jan 2009
Location: CANADA
Age: 44
Posts: 1,225
Thanks: 6
Thanked 48 Times in 45 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

check oil level. if it is low and sark it may be a possiblity that the catalyst got sucked back into the engine and now caused engine damage.
Reply With Quote
  #8  
Old 09-03-2009, 04:38 PM
ardenmann's Avatar
ardenmann ardenmann is offline
Tech Enthusiast
1994 Altima
 
Join Date: Sep 2009
Posts: 129
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

It's nissan design flaw. Pre-catalyst is located very close to engine in exhaust stream such that during high EGR flow conditions it is possible for exhaust gases (as designed) and bits of the catalyst (NOT planned) to enter the combustion cylinder. These pieces of ceramic and platinum (and other metals) in your combustion chamber are the equivalent of poring sand into your engine, which destroys the cylinders.
ALL DEALER MECHANICS ARE AWARE OF THIS PROBLEM; http://www.carcomplaints.com/Nissan/Altima/2002/
catalytic converter by law are covered for 80k miles. Take it to your Nissan dealer and chances are they will replace your motor under the cats 80k warranty



Last edited by ardenmann; 09-03-2009 at 05:07 PM.
Reply With Quote
  #9  
Old 09-03-2009, 05:47 PM
streamcast's Avatar
streamcast streamcast is offline
Master Enthusiast
1997 Altima
1995 Sentra
1995 Nissan sentra
 
Join Date: Jan 2009
Location: CANADA
Age: 44
Posts: 1,225
Thanks: 6
Thanked 48 Times in 45 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Actually there is a recall for this issue. But the recall may already performed on this vehicle. Not to say that it has repeated failure. You have tocontact the dealer with vin and check for incomplete recalls. What Law are you refering to?I would like to have some documentation in regards to this.
Reply With Quote
  #10  
Old 09-03-2009, 07:37 PM
ardenmann's Avatar
ardenmann ardenmann is offline
Tech Enthusiast
1994 Altima
 
Join Date: Sep 2009
Posts: 129
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

>>What Law are you refering to? I would like to have some documentation in regards to this.
http://www.epa.gov/otaq/consumer/warr95fs.pdf

A success story that is hard to come by:
The results for me were a complete new engine replacement, 2 new Cat converters, all done at Nissans expense, because of the recalls and the 80K warranty on Cat converters.
If you are having the sort of problems I have been reading here it might be a good idea to contact Nissan, give them your VIN#, and perhaps, luck out as I seem to have done.
http://townhall-talk.edmunds.com/dir...gine%22#MSG160

Last edited by ardenmann; 09-04-2009 at 04:12 PM.
Reply With Quote
  #11  
Old 09-04-2009, 07:24 PM
d0ugmac1's Avatar
d0ugmac1 d0ugmac1 is offline
Tech Enthusiast
2003 Altima
 
Join Date: Aug 2008
Posts: 160
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

#344 Same thread...LOL
Reply With Quote
  #12  
Old 09-07-2009, 07:02 AM
urtall1's Avatar
urtall1 urtall1 is offline
Registered User

2003 ALTIMA
 
Join Date: Feb 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

thanks for all your help on this issue. I can't collect on the 80K warrenty, as my vehicle has 128K on it. but I do believe that this is the exact issue that you all are talking to. I'm thinking I'm just going to trade it in for a honda or toyota, or sale it to some unsuspecting buyer. well, I will tell him that it needs a catalytic converter and possibly more. how much do you think I can get for it? this sucks. I just got this car paid for this year. was hoping for many years of no payments.
Reply With Quote
Reply

Bookmarks

Tags
2003, altima, nissan

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.0 Beta 2 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.