Login  |  Register
Nissanhelp.com - All About Nissan
All Models, All Years 2014 370Z Coupe 2014 370Z Coupe Nismo 2014 370Z Roadster 2013 Altima Coupe 2014 Altima Sedan 2014 Armada 2014 Cube 2014 Frontier Crew 2014 Frontier King 2014 GT-R 2014 JUKE 2014 JUKE NISMO 2013 Leaf 2014 Maxima
2014 Murano 2013 CrossCabriolet 2013 NV Cargo 2013 NV Passenger 2013 NV200 2014 Pathfinder 2014 Pathfinder Hybrid 2014 Quest 2014 Rogue 2014 Sentra 2014 Titan Crew 2014 Titan King 2014 Versa Note 2014 Versa Sedan 2014 Xterra Concept Models
MyNissan Do-It-Yourself Maintenance Owners Manuals Recalls/Campaigns Service Bulletins Service Manuals Tech Challenge Game Nissan OBDII Codes Glossary & Acronyms Cost Estimator More...
Member's Ride Photos Stock Photo Gallery
Classifieds - For Sale Classifieds - Wanted To Buy Classifieds - Mechanic Wanted Classifieds - Auto Services Search Auto Parts Ultimate Reflector Auto Sun Shades Custom Fit Car Covers Auto Snow Shades Berber Auto Mats Coco Auto Mats Designer Auto Mats Diamond Plate Auto Mats Fashion Auto Mats Flexomats Auto Mats Hexomats Auto Mats
Register FAQ Social Groups Mark Forums Read
Forums Nissan Models Altima SES Light Code # P0442
Forgot Password? Join Us!


Altima Nissan Altima Sedan Discussion Forum

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02-27-2009, 08:51 AM
bdaltima02's Avatar
Registered User
2002 Altima
 
Join Date: Feb 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Angry SES Light Code # P0442

I would appreciate any help I can get on this issue. My 02 Altima was taken to the dealer for all the recalls a week after passing NJ state inspection and a day after we left the dealer, SES light came on. I took the car back to Sansone dealer and they charged me $100 plus tax to tell me the code is P0442 and wanted $840 to fix. How is that possible?
Thank you in advance for your help.
bdaltima02
Reply With Quote
  #2 (permalink)  
Old 02-27-2009, 09:00 AM
buckeye3.5L's Avatar
Enthusiast
2005 Altima
 
Join Date: Feb 2009
Posts: 32
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default PO442

Evaporative Emission Control System Leak Detected (small leak). That's what the code is. Wait to see if a tech. responds...
Reply With Quote
  #3 (permalink)  
Old 02-27-2009, 09:23 AM
tech22's Avatar
Master Enthusiast
2005 Frontier Crew Cab Frontier Crew Cab
05 nissan frontier
 
Join Date: Jan 2008
Location: alliance,ohio
Age: 61
Posts: 2,049
Thanks: 0
Thanked 12 Times in 11 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Do this first,remove the gas cap and check for a clean gasket on the cap .Clean if debre is found. Next, look for rust on the sealing surface of the filler neck.Remove if found to have any.You need a clean surface on both.Now go to advance auto/auto zone and have them clear the code(free).If the lite comes back on then we can go from there.The p0422 is a small evap leak between the gas tank and the engine.But first do the list above to rule out the gas cap.It's a common problem on so vehicles in salt states.
Reply With Quote
  #4 (permalink)  
Old 02-27-2009, 10:48 AM
bdaltima02's Avatar
Registered User
2002 Altima
 
Join Date: Feb 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

The receipt they gave me says: Evap Canister is clogged. Is there anyway un unclogged without replacement.
Reply With Quote
  #5 (permalink)  
Old 03-04-2009, 05:00 PM
mrbizness1's Avatar
Enthusiast
2009 Murano
2007 Maxima
2009 Murano
 
Join Date: Nov 2008
Location: Mt. Sinai NY
Posts: 82
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Quote:
Originally Posted by bdaltima02 View Post
The receipt they gave me says: Evap Canister is clogged. Is there anyway un unclogged without replacement.
You can clear it easily yourself. First remove any of the hoses going to the canister and blow them out. I used a can of a air with the nozzle inserted into the hoses. You should also remove the evap vacuum pump that is attached to the canister and blow that out and use a small screwdriver to verify the plunger moves slightly.
I found a moth nest in one of the evap hoses that set off the light.
The ecm checks the evap system at different intervals so unless you clear the codes after the repairs it will take a few days for the light to go off.
Reply With Quote
  #6 (permalink)  
Old 03-04-2009, 05:13 PM
bdaltima02's Avatar
Registered User
2002 Altima
 
Join Date: Feb 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Big thanks to you all!
Reply With Quote
Reply

Bookmarks

Tags
code, light, p0442, ses

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -8. The time now is 05:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.